Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi have ProFTPD runningon a brand new CentOS 5.8 server with Plesk, and its behaviour is inconsistent at best. I tried to transfer a directory from my PC, and every time I get a transfer failed on a random file. It's never the same one that fails, it just fails. Sometimes it's a .gif, sometimes it's a .css, sometimes it's a JPG. Of several hundred files, a dozen is always failing for no apparent reason.

The error that I get is the following:

COMMAND:>   [27/11/2012 11:43:52] STOR main_border.gif
        [27/11/2012 11:43:53] 500 Invalid command: try being more creative
ERROR:>     [27/11/2012 11:43:53] Syntax error: command unrecognized.

The above is just an example, the "command unrecognized" occurs with LIST and other commands as well.

Here's the ProFTPD configuration, just in case:

ServerName                      "ProFTPD"
#ServerType                     standalone
ServerType                      inetd
DefaultServer                   on
<Global>
DefaultRoot     ~               psacln
AllowOverwrite          on
</Global>
DefaultTransferMode     binary
UseFtpUsers                     on

TimesGMT                        off
SetEnv TZ :/etc/localtime
Port                            21
Umask                           022

MaxInstances                    30

ScoreboardFile /var/run/proftpd/scoreboard

TransferLog /usr/local/psa/var/log/xferlog

#Change default group for new files and directories in vhosts dir to psacln

<Directory /var/www/vhosts>
        GroupOwner      psacln
</Directory>

# Enable PAM authentication
AuthPAM on
AuthPAMConfig proftpd

IdentLookups off
UseReverseDNS off

AuthGroupFile   /etc/group

Include /etc/proftpd.include

Note: file /etc/proftpd.include is blank.

The above is the default configuration set by Plesk 11. I don't know much of why is that way, my knowledge of Linux System Administration is very basic and the one of ProFTPD is a complete zero.

Thanks in advance for the help.

Update
Issue experienced with CuteFTP and FileZilla.

Update
Replaced ProFTPd with PureFTPd, issue persists. Sometimes I get "command unrecognized", sometimes "failed to establish data connection". I'm starting to think that it could be a network issue, but I have completely zero knowledge of networking.

share|improve this question
    
Try using a different FTP client. –  Michael Hampton Nov 27 '12 at 13:37
    
@MichaelHampton Thanks, but I'd like to fix the problem. My FTP client works with every single FTP server I have, except for this one, and I don't want to start using a different tool every time. –  Diego Nov 27 '12 at 13:47
    
Try it anyway. It's called troubleshooting. –  Michael Hampton Nov 27 '12 at 13:48
    
Pureftpd is a buggy ftp server, try vsftpd. –  FINESEC Nov 27 '12 at 21:41
    
ProFTPd seems to be even worse than PureFTPd. Anyway, I found a solution (I think). –  Diego Nov 27 '12 at 21:51

1 Answer 1

It seems that I found a solution to the issue, although I can't connect the dots: despite Passive mode being enabled in both ProFTPd and PureFTPd, transfers were done in Active mode, which caused all the troubles.

However, when I tried to force my client to Passive mode, the transfer could not be initiated, despite the required ports being (apparently) open. I therefore tried rebooting the server, which I think reloaded the firewall rules, and now transfer can be done in Passive mode, which is faster and, apparently, more stable.

So far I've managed to transfer a thousand of files correctly, therefore I consider the issue resolved.

Thanks everybody for all the suggestions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.