Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install composer (though to be honest I really have no idea how it fully works and documentation seems to be quite poor) on my MediaTemple DV machine. I am using their instructions

Trying to install globally using:

$ curl -s https://getcomposer.org/installer | php

My command line (again using putty and logged into my server as root) thinks for a second, then sets up for next prompt. I run a simple ls -l to check for the file it should have downloaded with no luck.

Any idea what could be causing the issue? I have tested and do in fact have curl installed.

UPDATE 1

Based on the first answer, the verbose response is:

$ curl -vs https://getcomposer.org/installer | php
* About to connect() to getcomposer.org port 443
*   Trying 37.59.4.156... connected
* Connected to getcomposer.org (37.59.4.156) port 443
* successfully set certificate verify locations:
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt   CApath: none
* SSLv2, Client hello (1): SSLv3, TLS handshake, Server hello (2): SSLv3, TLS handshake, CERT (11): SSLv3, TLS handshake, Server key exchange (12): SSLv3, TLS handshake, Server finished (14): SSLv3, TLS handshake, Client key exchange (16): SSLv3, TLS change cipher, Client hello (1): SSLv3, TLS handshake, Finished (20): SSLv3, TLS change cipher, Client hello (1): SSLv3, TLS handshake, Finished (20): SSL connection using DHE-RSA-AES256-SHA
* Server certificate:
*        subject: /C=CH/CN=dl.packagist.org/emailAddress=x6g02fqayn7d1itqtw2t@a.o-w-o.info
*        start date: 2012-07-07 23:25:35 GMT
*        expire date: 2013-07-10 02:55:12 GMT
* SSL: certificate subject name 'dl.packagist.org' does not match target host name 'getcomposer.org'
* Closing connection #0
* SSLv3, TLS alert, Client hello (1):
share|improve this question

1 Answer 1

up vote 2 down vote accepted

Try executing curl in verbose mode (-v):

curl -vs https://getcomposer.org/installer | php
share|improve this answer
    
posting code above based on your response. –  JM4 Nov 27 '12 at 21:56
    
there's a problem with SSL certificate, add -k to curl to allow connections to SSL sites without certs –  FINESEC Nov 27 '12 at 22:08
    
I'm assuming somebody saw this on their end because I just tried a second time and it worked. Thanks for your help! –  JM4 Nov 27 '12 at 22:09
    
I ran into this same problem and adding -k worked for me. –  DavidDraughn Feb 11 '13 at 16:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.