Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

One user at my site has reported that he reaches the content at /var/www when browsing to any of the vhosts at my server. As far as I’m aware, my Apache server does not contain a document root that references this folder. On top of that, this user seems to be the only one experiencing the issue. According to his ISP, the issue isn’t caused by them, yet, on his mobile connection, he can access the site. When browsing to my server’s IP, he also receives the correct content from the default vhost.

What could be the possible causes of this issue and how can I get it to stop? I’ve explored pretty much every option I could think of.

share|improve this question
    
Can you see the client's requests in the server logs? It's likely the mobile client is not sending the correct host in the HTTP requests. You should be able to see this in the Apache logs if you have that log option enabled. If not and you can't enable it you should be able to see it in a packet capture. –  Nathan V Dec 4 '12 at 11:15
add comment

migrated from superuser.com Nov 28 '12 at 8:35

This question came from our site for computer enthusiasts and power users.

5 Answers

Look carefully at all request headers that come from client. It may be some headers sent by his provider's proxy server.

Not exactly same issue but there was a client which has gained access to the admin panel of something just by using a proxy server. His proxy sent the X-Forwarded-For: 192.168.0.something header which was taken as the real IP address by server software. And it turned out that admin access was only restricted by local IP address.

share|improve this answer
    
The requests from his IP don't seem to contain anything out of the ordinary. –  FHannes Dec 7 '12 at 18:21
add comment

Did you switch DNS recently? It sounds like the ISP are mistaken, and are in fact caching an old DNS entry. I've run into this a couple of times in the past. Only after the ISP flushed things on their end was the problem resolved.

share|improve this answer
    
I told the user to change his DNS servers to Google DNS, flush his DNS cache and try again, but he says he still gets the same results. –  FHannes Nov 28 '12 at 12:40
    
That's all fine and good, but there is a level of caching that takes place at the ISP. I experienced an issue with an ISP reseller in Wisconsin (in the boonies). They refused to acknowledge that the rest of the civilized world was seeing the new site, but only the client under their wonderful service was seeing the old site. They did something on their end and 24 hours later the problem went away. Just saying... –  Ian Atkin Nov 29 '12 at 8:32
    
Well, my DNS hasn't changed for over a year, so I doubt it's a caching issue. –  FHannes Nov 29 '12 at 17:40
add comment
  1. Verify that the user is getting the right DNS DATA. Have the user open a shell or use a local system tool to look up the domain name and report the IP to you.
  2. IF he is getting the wrong IP, figure out where he gets his DNS. Don't assume he actually uses his ISP's DNS. Verify his DNS settings and don't forget to check the HOSTS file.
  3. If he gets the right IP, verify that there isn't a caching WEBFILTER between him and the network that might need its cache purged.
  4. Verify that he is getting to the network without passing through a PROXY, check his browser settings!
share|improve this answer
add comment

I'd be curious if the user is using a browser that isn't using HTTP/1.1, but rather HTTP/1.0 requests that don't pass the hostname with the request. It sounds as if there's no identifying site information to trigger your web server to serve up the right page, so it's landing on the default web root. Perhaps you could encourage him to attempt a different browser as a troubleshooting step.

If you want to test that theory, you could get his IP and search the logs for it to see what he's sending. If there's any question as to whether he is accessing your site or another, you could attempt to put up a file in /var/www and direct him to that file as a test. Alternatively, you could configure your default webroot to point to a site you host that makes the most sense.

share|improve this answer
    
If I recall correctly, he uses Chrome, however, my own software which he uses as well, uses the HTTP protocol to download updates, and this doesn't seem to be working either. The downloaded files are corrupt, so I assume it's just downloading that same wrong page for some reason. –  FHannes Dec 7 '12 at 18:12
    
On a side-note, my default webroot is not the default apache folder, so I don't understand why it'd even display. –  FHannes Dec 8 '12 at 18:07
add comment

Try checking your DNS settings from intodns.com I was having almost same trouble. This website reported some errors with my dns, after correcting them, i managed to make it work.

share|improve this answer
    
That's a VERY helpful site, thank you. Aside from the fact that I have a single point of failure, with my DNS located on a single server, it reported that the nameserver in my SOA record is not listed by my parent DNS. Which is true, but this hostname points to the same server that holds my DNS, so that shouldn't be an issue. I've fixed the issues, but I don't think this will resolve the problem. –  FHannes Dec 4 '12 at 18:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.