Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a couple of virtual machines (running Scientific Linux 6.2) that publish Workstation records so that they can easily be found on the net. Some of the virtual machines stop publishing after a few minutes, i.e. I can reach them via hostname.local for a few minutes and then any discovery will time out. They are still reachable via their IP address. Restarting avahi-daemon results in the same behaviour.

There is nothing in /var/log/messages that would indicate a problem:

Nov 27 08:07:33 vm01 avahi-daemon[2836]: Got SIGTERM, quitting.
Nov 27 08:07:33 vm01 avahi-daemon[2836]: Leaving mDNS multicast group on interface eth0.IPv4 with address 10.100.200.226.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Found user 'avahi' (UID 70) and group 'avahi' (GID 70).
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Successfully dropped root privileges.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: avahi-daemon 0.6.25 starting up.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: WARNING: No NSS support for mDNS detected, consider installing nss-mdns!
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Successfully called chroot().
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Successfully dropped remaining capabilities.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: No service file found in /etc/avahi/services.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Joining mDNS multicast group on interface eth0.IPv4 with address 10.100.200.226.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: New relevant interface eth0.IPv4 for mDNS.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Network interface enumeration completed.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Registering new address record for fe80::216:3eff:fe73:df12 on eth0.*.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Registering new address record for 10.100.200.226 on eth0.IPv4.
Nov 27 08:07:33 vm01 avahi-daemon[2880]: Registering HINFO record with values 'X86_64'/'LINUX'.
Nov 27 08:07:34 vm01 avahi-daemon[2880]: Server startup complete. Host name is vm01.local. Local service cookie is 320168790.

There is nothing further in the log that would indicate a problem. The SIGTERM during startup seems to be normal, a cursory google'ing showed that.

I only modified entries in the publish section of the configuration; everything else was left as-is:

[publish]
disable-publishing=no
disable-user-service-publishing=no
#add-service-cookie=no
publish-addresses=yes
#publish-hinfo=yes
publish-workstation=yes
#publish-domain=yes
#publish-dns-servers=192.168.50.1, 192.168.50.2
#publish-resolv-conf-dns-servers=yes
#publish-aaaa-on-ipv4=yes
#publish-a-on-ipv6=no

The avahi-daemon does not produce any significant cpu load. The process is running:

# ps auxww |grep avahi
avahi     2880  0.0  0.0  27660  1488 ?        S    08:07   0:00 avahi-daemon: running [vm01.local]
avahi     2881  0.0  0.0  27660   520 ?        Ss   08:07   0:00 avahi-daemon: chroot helper

I have some virtual machines with CentOS 5.8 and they do not have this problem. They have avahi-daemon 0.6.16 and the same configuration. Any ideas?

share|improve this question

migrated from superuser.com Nov 28 '12 at 14:20

This question came from our site for computer enthusiasts and power users.

    
Thanks for the move! –  arne Nov 28 '12 at 14:55
add comment

1 Answer 1

Just realized I'm about to respond to a really old question, but maybe someone will find this useful.

Have a look at your network equipment, specifically any managed switches. I've run into issues with IGMP snooping, where multicast requests might suddenly stop being received by clients after a few minutes because the switch was filtering it out.

Food for thought.

share|improve this answer
    
Wow. Never thought about that. Will pester the admins momentarily. –  arne Dec 20 '13 at 8:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.