Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

This question already has an answer here:

I'm having a really unique issue with a local development environment. I currently have a WAMP Stack Running on ZendServer. On my computer, by default, port 80 is occupied, so I am using port 8080, and I'm having no issues with this whatsoever.

This issue first came to my attention when I started with a local WordPress install, and I can view the homepage and access the backend of WordPress with no issues. I can add/edit posts with no issues. I originally set up a vhost to have zr‑ to map into my htdocs folder and that works with no issues.

What then happens is that I go on the home page, then try to go to any page other than the home page (on the front end), and I get a 404 Not Found error. It is an exact clone of the live site, and when I test it on a linux-based LAMP Stack (Ubuntu) it works with no issues.

Any clarification on this would be greatly appreciated.

share|improve this question

marked as duplicate by HopelessN00b Feb 25 at 6:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Sounds like a mod_rewrite issue. Is it installed and enabled? –  John Gardeniers Nov 29 '12 at 10:22

1 Answer 1

up vote 0 down vote accepted

You forgot your WordPress rewrite rules. Make sure you enabled mod_rewrite and have the appropriate bits in .htaccess.

share|improve this answer
Here is my .htaccess file's contents, I do not think that is the issue # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase /trafficbarricade/ RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /trafficbarricade/index.php [L] </IfModule> # END WordPress –  Zach Russell Nov 28 '12 at 17:41
That's only half the story. Do the other thing: Enable mod_rewrite. –  Michael Hampton Nov 28 '12 at 17:42
It's enabled in the httpd.conf file (IE it's uncommented). I'm looking at the file and it basically looks like each row has 8 sets of 4 alphanumeric characters, is that right? –  Zach Russell Nov 28 '12 at 17:45
You restarted Apache after enabling mod_rewrite? Is it really enabled? –  Michael Hampton Nov 28 '12 at 17:51
I've mod_rewrite was always enabled as far as I know, how do I check f it's "really enabled" on windows? –  Zach Russell Nov 28 '12 at 18:02

Not the answer you're looking for? Browse other questions tagged or ask your own question.