Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Before anything else, hello guys, this is the first time I ask for something here so I hope someone can give me a hand, please look at the following network diagram:

---------------------------------------------------------------                      
VPN Server              Webserver
(SuSE SLES11)              |
     |                      |               
     ------- VPN LAN -------- 
     |
   Router with Unique IP (With Port Forwarding rules set and VPN through enabled)    
     |
PPTP connection over Internet
     |
Workstation
(PC or Laptop with Windows)
---------------------------------------------------------------

So the idea is for the workstation to connect to the PPTP Server and then be able to access a Web Application on the Webserver, right now I have the PPTP server configured and the VPN works, I can connect to the SLES11 server with no problems from the workstation and I can ping it and everything works fine but if I try to ping the Webserver from the workstation, I can't reach it, I'm making a mistake somewhere but I don't see where, please note that I'm not a network expert and thus I'd greatly appreciate some specific guidance.

Here is some info related to the IPs

---------------------------------------------------------------
*** SLES11 VPN Server has 2 Network cards:
-- eth0 (Internal Network)
IP:  192.168.210.5 
MASK: 255.55.255.0

-- eth1 (External Network)
IP: 192.168.1.105
MASK: 255.55.255.0

*** Webserver has 1 network card
-- eth0 (Internal Network)
IP:  192.168.210.221 
MASK: 255.55.255.0

*** Workstation
-- IP info once connection has been established to the VPN
PPP adapter Test VPN Connection:
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Test VPN Connection
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.210.110(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . : 0.0.0.0
   DNS Servers . . . . . . . . . . . : 189.209.208.181   (Defined as part of the PPTP Server options config script)
                                       189.209.127.244
   Primary WINS Server . . . . . . . : 192.168.210.220   (Defined as part of the PPTP Server options config script)
   NetBIOS over Tcpip. . . . . . . . : Enabled
---------------------------------------------------------------

I also defined the following within IP tables:

-------------------------------------------------------------
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
iptables -A INPUT -i eth0 -p tcp --dport 1723 -j ACCEPT
iptables -A INPUT -i eth0 -p gre -j ACCEPT
-------------------------------------------------------------

If you need any piece of information from the PPTP server scripts please let me know, the thing is that I can actually connect to the VPN server and access its services and everything but after that I can't reach any other computer on that LAN. Any help would be greatly appreciated and thanks in advance

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.