Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Had a new Axis IP camera delivered yesterday. Plugged into Cisco E2400 Wireless Router but having problems.

Example topology:

  • WAN IP: 82.10.10.10 (example)
  • Cisco Router: 192.168.1.1
  • Axis Camera: 192.168.1.10:80

Port forwarding rules set up on router

  • External Port: 999
  • Internal Port: 80
  • Protocol: TCP & UDP
  • Device IP: 192.168.1.10:80
  • Enabled: True

Trying to connect from within the lan to 192.168.1.1:80 from within browser - Works properly.

Trying to connect from within the lan to 82:10:10:10:999 from within browser - Works properly.

Trying to connect from outside the LAN (e.g. via 3g or another isp) to 82:10:10:10:999 from within browser - Doesnt work.

I get the following errors from different machines / browsers:

  • Safari could not open the page because the server stopped responding (IOS)
  • The server at 82.10.10.10 is taking too long to respond. (firefox)

This problem is not just for the Axis camera. I am also having similar problems connecting to my NAS drive.

After using a web based port scanning tool, it appears as though port 999 is closed. Not certain why when I have set up port forwarding within the router.

Any troubleshooting suggestions to help me determine whether the problem is with my Cisco settings / firewall or whether it could be my ISP blocking incoming connection requests?

Many thanks

share|improve this question
1  
Does your public IP actually start with 10.? If so, it's unlikely you'll ever be able to get this to work. –  EEAA Nov 29 '12 at 3:01
    
1. Do you mean Linksys E4200? 2. Is your "WAN IP" really a private address? –  Michael Hampton Nov 29 '12 at 3:05
    
Amended. WAN Ip address is 82.XX.XX.XX –  Gravy Nov 29 '12 at 16:27
add comment

1 Answer 1

I'm guessing that indeed your ISP is blocking the port 999. Some ISP's block all ports under 1024. Try forwarding a higher port on your router (f.e. 9999) to the ip camera and see if that works.

share|improve this answer
    
Thanks, I will try that and let you all know. –  Gravy Nov 29 '12 at 16:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.