Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On our Cisco WLAN Controller web interfaces, in Controller > Interfaces, I have made a new interface with these settings:

VLAN Identifier 202

IP Address 172.16.202.1

Netmask 255.255.255.0

Gateway 172.16.202.254

Primary DHCP Server 172.16.100.3

Secondary DHCP Server 172.16.100.2

Port: LAG

I've also made a new WLAN and assigned it to the above interface. I have saved changes. But our wireless devices, although they seem to authenticate with the WLAN fine, they always get stuck on "obtaining DHCP address", so it seems the WLAN Controller isn't pushing out DHCP addresses to our devices.

We do have a DHCP scope for the above in Windows Server 2008 R2 and everything there seems fine.

If I connect a device with a static address (e.g. 172.16.202.10), it will connect. Stuck on what to do :(

share|improve this question
1  
sometimes wireless devices need to manually set the vlan ID? also triple check the controller is not sending out DHCP too –  Cold T Nov 29 '12 at 10:24

2 Answers 2

It is possible your Router is blocking DHCP requests. This is a common option in many routers. One way to fix this is allow DHCP traffic to pass trough the router. Another option is make the router a relay aswell and have that as server set in your wlan controller so your config would be client -> wlan controller -> router -> win2008 box.

share|improve this answer
    
If the router is dchp-relay there is no need to add it as a fake DHCP server. In fact this may actually have an adverse effect in some circumstances. –  Tonny Nov 29 '12 at 11:02
    
On the Cisco switch if I do show ip route, I can immediately see all the VLANs in a list but not the 202 one. This must be the problem so it's probably a routing issue. But I thought we did add the VLAN. Where are we going wrong with why the vlan 202 isn't coming in show ip route? –  Name Nov 29 '12 at 13:00
    
Thanks all for your replies. We've managed to fix it, it was related to the VLAN not appearing when doing show ip route. The solution was to create the VLAN in this way: switch# configure terminal switch(config)# vlan 202 switch(config-vlan)# name wirelesstablets switch(config-vlan)# state active switch(config-vlan)# no shutdown show ip route (to confirm) –  Name Nov 29 '12 at 14:05

ip helper-address DHCP server ip is what I used in my labs to get UDP broadcasts forwarded to my DHCP server.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.