Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two different networks in two different offices interconnected using OpenVPN. The windows 2003 server (AD) on one network can now talk to all the machines in the main network where OPENVPN server is running on (This is based on Linux environment which I am more comfortable with configuring) however, I am struggling to figure out why bridging using Windows 2003 method between two NICs (one of which is TAP-32 Adapter) is not working for me.

Example:

The Windows 2003 has 1 NIC for the local network 192.168.16.0/24 and the OPENVPN TAP adapter which is on 192.168.5.0/20 but everytime I bridge the two adapters, both networks are being dropped.

Would I need to do something special on ESX to enable bridging becaused based on this tutorial ( http://www.pavelec.net/adam/openvpn/bridge/ ) on how to enable bridging - it should be straight forward but, it doesnt do the trick for me. The bridge is created but no traffic flows

With thanks,

share|improve this question
    
Please do not cross-post. If we think a Question should be on another site, we'll migrate it. Thank you and welcome to Stack Exchange –  Chris S Nov 29 '12 at 16:04
    
Chris, I have been advised to move it to this site moreover, I was not even aware the two sites were connected –  ani Nov 29 '12 at 16:15
    
When you bridge the networks, you are bridging the networks at layer 2. You shouldn't have two separate subnets after you bridge a network. Are you sure bridging is really what you want? Or should you be routing between the networks? –  Zoredache Nov 29 '12 at 17:50
    
I have also tried routing but, the same issue, the two networks are not talking to each other –  ani Nov 29 '12 at 21:44

1 Answer 1

vmware ESX used vmswitch to manage the network and it doesnt work like a real switch, it just accept the VM mac address and reject other "unknown" (to the esx) mac address.

the solution is to enable the vmswitch promiscuous mode (switch from reject to accept) so the vmswitch can accept the foreign mac address

please see this reply about the same topic

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.