Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason, I am unable to access our website (Bad request nginx). We are hosted on amazon EC2 with elastic IP associated to it. The weird part is

  1. I can access it through the public dns url
  2. My co founder who is located in another city can access it via

I observed that my instance was failing reachability check, so I launched a new one and assigned it the the elastic IP. I tried to ping the IP address from my machine but no success. Any help will be really appreciated.

More details I ran the following command on my server

netstat -lntp | grep -E 'apache|httpd'

and it displays


for httpd . Is this accurate ? Should it be 0:0:0:80? or does it not matter?

share|improve this question

The problem is you have set the wrong IP address in the DNS.

error@underground ~ $ host has address
error@underground ~ $ host has address

Once you fix this, you should find things start working.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.