Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My server is rejecting emails from one external sender. I suspect this might be misconfiguration on the sending server, but I'm not sure from these error messages.

The non-delivery report message the sender gets contains this text:

#5.7.1 smtp;550 5.7.1 Command rejected> #SMTP#

I also see this message in /var/messages at about the same time as the rejection message was sent, though I'm not sure if it's actually related:

Nov 29 12:29:28 localhost postfix/smtpd[31829]: sql_sqlite3 plugin: no result found

I'm using Plesk 10.4.4 Update #47, Centos 6.2, Postfix 2.8.4-11100615 on my mail server.

This is only happening for one sender so far, but I found a Google result on experts-exchange.com which seemed to identify the same problem and with the same sending domain. This was posted back in June, and currently has no answers, so even if I was a paying customer it wouldn't be answered. (http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Q_27760746.html)

The generating server is bigfish.com.

What I need to determine is if this is a problem on my server or a problem with bigfish.com. Is there more information I can find in config files, logs, etc. to figure this out?

share|improve this question
2  
Include the output of postconf -n with your post, as well as the complete, non-verbose log for a single queue-ID. –  adaptr Nov 30 '12 at 10:46
add comment

2 Answers

up vote 2 down vote accepted

Don't know if you have the same issue as I had, but this fixed it for me: https://www.unixcafe.de/2012/04/e-mails-und-plesk/

With this command you change the default configuration of greylistings backlist filtering:

/usr/local/psa/bin/grey_listing --update-server -domains-blacklist del:"dsl|pool|broadband|hsd"

Plesk Spam and Greylisting block in their default configuration: dsl|pool|broadband|hsd.

And Microsoft uses pool in their server domain name: (ch1outboundpool.messaging.microsoft.com)

To be absolutely sure the changes are used also check this command and see if the SQLite Database of greylisting actually updated (some users reported issues that the first command did not do the trick). To verify this, run the following command. It selects the actual patterns from the sqlite database:

sqlite3 /var/lib/plesk/mail/greylist/settings.db "select * from remote_domains"

To actually remove the offending pattern, try this command:

sqlite3 /var/lib/plesk/mail/greylist/settings.db "delete from remote_domains where domain = 'dsl|pool|broadband|hsd'"

And this command also does not hurt (whitelisting microsofts domain name):

/usr/local/psa/bin/grey_listing --update-server -domains-whitelist "add:*messaging.microsoft.com"

share|improve this answer
add comment

You could try to configure the smtpd process in /etc/postfix/master.cf with -v and reload the configuration. You should see a lot more output from the smtp subprocess in the log file when a message is coming in, which should include things related to handling of bad SMTP protocol commands.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.