Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running a vps with ubuntu 11.04. After a clean Modx install I've tried to access and I've got a permission denied by my server. the thing is that I can easily access any other folder under that domain and modify this folder(manager) content via ftp. I’ve tried modifying virtual host with that

<Directory /var/www/blackflow/data/www/>
 Options Indexes FollowSymLinks ExecCGI
AllowOverride All
Order allow,deny
Allow from all

But it didn't work.

<Directory /var/www/blackflow/data/www/>
    Options -ExecCGI -Includes
    php_admin_value open_basedir "/var/www/blackflow/data:."
    php_admin_flag engine on

<VirtualHost >
    CustomLog /var/www/httpd-logs/ combined
    DocumentRoot /var/www/blackflow/data/www/

    ErrorLog /var/www/httpd-logs/
    SuexecUserGroup blackflow blackflow
    AddType application/x-httpd-php .php .php3 .php4 .php5 .phtml
    AddType application/x-httpd-php-source .phps
    php_admin_value open_basedir "/var/www/blackflow/data:."
    php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -f"
    php_admin_value upload_tmp_dir "/var/www/blackflow/data/mod-tmp"
    php_admin_value session.save_path "/var/www/blackflow/data/mod-tmp"
    VirtualDocumentRoot /var/www/blackflow/data/www/%0


Any ideas on what might have gone wrong?

share|improve this question
What do you see in the logs (/var/www/httpd-logs/ and /var/www/httpd-logs/ when you try to access it? – yoonix Nov 30 '12 at 15:51
Permission denied: /usr/local/ispmgr/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable – Michał Korzeniowski Nov 30 '12 at 16:04
up vote 1 down vote accepted

The permissions for one of the directories above that file (or the .htaccess file itself) most likely has improper permissions set to use it.

Check the permissions of '/usr/local/ispmgr', '/usr/local', and '/usr/' until you find which directory has the invalid permissions. The web server needs at a minimum execute (+x) permissions to be able to read a file within that directory.

Try 'chmod a+x /usr/local/ispmgr /usr/local /usr' and 'chmod a+r /usr/local/ispmgr/.htaccess' if you aren't familiar with setting permissions to get started.

share|improve this answer
it's getting more and more interesting:/. When I chmod /usr/local/ispmgr redirects me to my ispmanager login page! As for the .htaccess file I couldn't find one so I've made a blank one. Now I get that error: /usr/local/ispmgr/.htaccess: Invalid command '------WebKitFormBoundary5SydCNWPKSjdR0zF', perhaps misspelled or defined by a module not included in the server configuration. – Michał Korzeniowski Nov 30 '12 at 16:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.