Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I migrated my server to a new provider and have postfix & everything else back up and running, but am not getting incoming mails greylisted anymore when I have postgrey running. I was on CentOS 5.7 previously and now on Ubuntu 12.04 LTS

postgrey is running

$ ps ax |grep postgrey
 1330 pts/0    S+     0:00 grep --color=auto postgrey
32664 ?        Ss     0:00 /usr/sbin/postgrey --pidfile=/var/run/postgrey.pid --daemonize --inet=10023 --delay=60

And is listening on port 10023

$ netstat -nlpa | grep postgrey
tcp        0      0 127.0.0.1:10023         0.0.0.0:*               LISTEN      32664/postgrey.pid
unix  2      [ ]         DGRAM                    331119   32664/postgrey.pid

And here is the smtpd_recipient_restrictions portion of my postfix main.cf, where i'm telling postfix to check postgrey via check_policy_service inet:127.0.0.1:10023

smtpd_recipient_restrictions =
        permit_mynetworks,
        reject_invalid_hostname,
        reject_non_fqdn_sender,
        reject_non_fqdn_recipient,
        reject_unknown_sender_domain,
        reject_unknown_recipient_domain,
        reject_unauth_destination,

        permit_dnswl_client list.dnswl.org,

        reject_rhsbl_reverse_client dbl.spamhaus.org,
        reject_rhsbl_sender dbl.spamhaus.org,
        reject_rhsbl_client dbl.spamhaus.org,
        reject_rhsbl_sender fresh15.spameatingmonkey.net,
        reject_rhsbl_client fresh15.spameatingmonkey.net,
        reject_rhsbl_sender uribl.spameatingmonkey.net,
        reject_rhsbl_client uribl.spameatingmonkey.net,
        reject_rhsbl_sender urired.spameatingmonkey.net,
        reject_rhsbl_client urired.spameatingmonkey.net,
        reject_rhsbl_client hostkarma.junkemailfilter.com=127.0.0.2,

        reject_rbl_client b.barracudacentral.org,
        reject_rbl_client zen.spamhaus.org,
        reject_rbl_client bl.spameatingmonkey.net,
        reject_rbl_client bl.spamcop.net,
        reject_rbl_client hostkarma.junkemailfilter.com=127.0.0.2,
        reject_rbl_client dnsbl.njabl.org,
        reject_rbl_client bl.tiopan.com,
        reject_rbl_client spamsources.fabel.dk,
        reject_rbl_client truncate.gbudb.net,
        reject_rbl_client ubl.unsubscore.com,
        reject_rbl_client aspews.ext.sorbs.net,
        reject_rbl_client dnsbl.sorbs.net,
        reject_rbl_client backscatter.spameatingmonkey.net,
        reject_rbl_client bl.spameatingmonkey.net,
        reject_rbl_client dnsbl.webequipped.com,
        reject_rbl_client psbl.surriel.com,

        check_policy_service inet:127.0.0.1:10023,
        permit

There shouldn't be anything else to the set up, right? I am not seeing anything getting NOQUEUE greylisted in my /var/log/mail.log, like i did with my previous setup on CentOS.

Is there a way for me to enable more verbose logging to see if postfix is communicating properly with postgrey and vice versa?

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

Going to answer my own question, as I figured out the issue...I was expecting test emails I was sending from gmail, yahoo, hotmail, etc. to be initially greylisted on this new machine, but they weren't because I am using the list.dnswl.org whitelist (via permit_dnswl_client list.dnswl.org), and those IPs likely appear on that whitelist.

I went back to check on the logs again after some time and am seeing emails whitelisted properly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.