Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are experimenting with Azure IaaS and see weird behavior. Here's what we did:

  1. Created a Windows Server 2008 R2 Core VHD.
  2. Uploaded it to Azure (not sysprepped).
  3. Created a VM against that VHD.
  4. Confirmed that I could RDP into the VM as both Administrator and a second Administrator account.
  5. Shut down the VM.
  6. Made a copy of the VHD in Blob Storage using the Azure API
  7. Created a new VM pointing at the copied VHD.
  8. Started the VM. It started fine.
  9. Attempted to RDP in to the VM.

The RDP session fails as either of the two users - access denied.

I downloaded one of the copied VHDs and created a VM locally in Hyper-V. I can see the VM boots properly and gets to the Ctrl-Alt-Del prompt. But sure enough, both users fail.

I attached the VHD as a local drive, and looked at Event Viewer. The code and subcode tell me it's a correct username, but incorrect password.

Any ideas?

share|improve this question
    
I have no ideas for you, but FWIW, I think that ought to have worked. –  codingoutloud Mar 22 '13 at 18:12
add comment

1 Answer

up vote 0 down vote accepted

So, I had a similar problem today, except the failure happened with the originally uploaded VHD. A known working username/password combination simply didn't work.

I fixed it this time doing the following:

  1. Shutting down the "bad" VM through the portal.
  2. Deleting the VM.
  3. Waiting for the lease on the VHD to be removed.
  4. Attaching the VHD as a secondary disk to a working VM.
  5. Using an offline editor (http://cdslow.webhost.ru/en/ntpwedit/ - which I can't seem to get to now) I reset the password to what it was already.
  6. Detaching the VHD from the assisting VM.
  7. Waiting for the lease on the VHD to be removed.
  8. Recreating the VM with that VHD.
  9. Booting and proving I could now sign in.

No idea why this was necessary. It shouldn't be. It's not consistent either; sometimes I need to do it, sometimes I don't. There must be something about the VMs but I have no idea what.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.