Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm sorry but i'm stuck in figuring out a problem i'm facing here. I removed the AD feature from server manager and after rebooting, my server 2012 gui wasn't there anymore. There's only command prompt to deal with. I tried to enable back gui based on threads i've found. I did SConfig but option no.12 which is to restore gui is not there. I tried running powershell but it stated "powershell is not recognized as internal or external...". I change my path to c:\windows\system32\windowspowershell\v1.0 and tried running powershell just to find the same error message. So how can i enable back the gui feature of my server 2012?

share|improve this question

2 Answers 2

up vote 15 down vote accepted

Is explorer simply not starting? have you tried typing explorer.exe in the command prompt window? I guess this isn't the case you wouldn't normally get a command prompt when logging in. It sounds like somehow the shell has been removed, effectively giving you a server core install, in which case try issuing the following from the command prompt. This should re-enable the shell if it has been somehow disabled.

Dism /online /enable-feature /featurename:Server-Gui-Mgmt /featurename:Server-Gui-Shell /featurename:ServerCore-FullServer
share|improve this answer
    
Yes. explorer.exe doesn't start as well. As far as I'm concerned, i only removed the AD feature without messing around with the shell. After rebooting, the gui went missing and I couldn;t even access the powershell to restore the gui. –  zorro Dec 1 '12 at 13:01
    
Okay have you tried running the dism command I suggested? If the shell has been removed (which sounds likely, although I've no idea why), then the dism command should sort it out. –  Bryan Dec 1 '12 at 13:18
    
Thank you so much ! –  zorro Dec 1 '12 at 13:45
    
Have you managed to resolve it? Your now deleted comment had me stumped. –  Bryan Dec 1 '12 at 13:51
1  
@user1867016 If the answer resolved your issue, be sure to accept it by clicking the outline of the check mark next to it. This indicates to others that the issue is resolved. Welcome to Server Fault! –  Michael Hampton Dec 1 '12 at 15:12

FYI, when this happened to me, I kept getting an Error 50 when using the command above. I had to add an /all to make it work. Once I did that, it worked just fine.

Dism /online /enable-feature /all /featurename:Server-Gui-Mgmt /featurename:Server-Gui-Shell /featurename:ServerCore-FullServer
share|improve this answer

protected by MDMarra Apr 24 '13 at 13:12

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.