Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm facing an interesting problem with plenty of Permission Denied outputs when using SymLinks

Linux: Slackware 13.1

Directory with Symlink:

root@Tower:/var/lib# ls -lah
drwxr-xr-x  8 root       root    0 2012-12-02 20:09 ./
drwxr-xr-x 15 root       root    0 2012-12-01 21:06 ../
lrwxrwxrwx  1 ntop       ntop   21 2012-12-02 20:09 ntop -> /mnt/user/media/ntop6/

Symlinked Directory:

root@Tower:/mnt/user/media# ls -lah
drwxrwx--- 1 nobody users  1.4K 2012-12-02 19:28 ./
drwxrwx--- 1 nobody users   128 2012-11-18 16:06 ../
drwxrwxrwx 1 ntop   ntop    320 2012-12-02 20:22 ntop6/

What I have done:

  • I have used chown -h ntop:ntop on the ntop directory in /var/lib
  • Just to be sure, I have chmod 777 to both directories

Permission denied actions:

root@Tower:/var/lib# sudo -u ntop mkdir /var/lib/ntop/test
mkdir: cannot create directory `/var/lib/ntop/test': Permission denied

Any ideas?

share|improve this question
May I ask the output of "mount"? – user130370 Dec 2 '12 at 11:18
Thanks Eric: /dev/md1 on /mnt/user type reiserfs (rw,noatime,nodiratime,user_xattr,acl) – John Smith Dec 3 '12 at 10:06
Is this because the thing that is mounted is read only? ie a DVD drive, or read-only nfs mount, etc/ – Sirch Mar 10 '15 at 14:28

Unless ntop is a member of users, he cannot enter /mnt/user or /mnt/user/media, as entering a directory requires +x permissions.

share|improve this answer
Thanks Dennis. But I still get the following errors: Dec 2 21:17:50 Tower ntop[13952]: WARNING INIT: Unable to create pid file (/var/lib/ntop/ Dec 2 21:18:00 Tower ntop[13952]: ERROR RRD: Disabled - unable to create base directory (err 13, /var/lib/ntop/rrd) – John Smith Dec 2 '12 at 10:21
That has nothing to do with the above. Please include the output of namei -m /var/lib/ntop with your question. – adaptr Jan 4 '13 at 14:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.