Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get PPTP installation up and running on my VPS. I have followed various guides, however, I am unable to connect to the VPN once it’s setup.

I checked my VPS’ /var/log/messages and I found this:

1832 Dec  2 23:38:55 server9987 pptpd[1470]: CTRL: Client 86.8.79.197 control connection started
1833 Dec  2 23:38:55 server9987 pptpd[1470]: CTRL: Starting call (launching pppd, opening GRE)
1834 Dec  2 23:38:55 server9987 pppd[1471]: Plugin /usr/lib/pptpd/pptpd-logwtmp.so loaded.
1835 Dec  2 23:38:55 server9987 pppd[1471]: This system lacks kernel support for PPP.  This could be because the PPP kernel module could not be loaded, or because PPP was not inc     luded in the kernel configuration.  If PPP was included as a module, try `/sbin/modprobe -v ppp'.  If that fails, check that ppp.o exists in /lib/modules/`uname -r`/net. See      README.linux file in the ppp distribution for more details.
1836 Dec  2 23:38:55 server9987 pptpd[1470]: GRE: read(fd=6,buffer=8059680,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termina     tion of pppd, check option syntax and pppd logs
1837 Dec  2 23:38:55 server9987 pptpd[1470]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
1838 Dec  2 23:38:55 server9987 pptpd[1470]: CTRL: Client 86.8.79.197 control connection finished

It says that my "system lacks kernel support for PPP." Could this be the cause of the problem, and if so, is there a solution?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You're almost certainly using an OpenVZ-based VPS. In this case, the host must enable the ppp kernel module (and anything else you might need) for you. Open a support ticket with your hosting provider.

If they are unable or unwilling to make this change for you, buy another VPS, that doesn't use OpenVZ, so that you can choose your own kernel modules.

share|improve this answer
    
Ahh, I see! Thank you. If they are unwilling to enable the ppp kernel module, is it worth me trying OpenVPN instead of PPTPD, or will I have the same problems? –  Oliver Joseph Ash Dec 2 '12 at 23:56
1  
OpenVPN would be a much better choice overall, since PPTP is horribly insecure. In this case, ask the OpenVZ provider to enable TUN/TAP support for you, and OpenVPN will work. (Other virtualization platforms normally run OpenVPN out of the box with no special intervention from the host.) –  Michael Hampton Dec 2 '12 at 23:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.