Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am unable to SSH into an existing ESXi server. I have a user which is in the "root" and "users" group and is able to connect via vSphere. However after enabling "Remote support (SSH)", attempting to connect by putty and entering my username/password when prompted I am presented with an "Access Denied" message.

I have run through the options presented at this KB article to no avail. I have taken down the firewall on the machine (it is remote) temporarily to check if this helped - no change.

The username/password are definitely correct and I can obviously get connectivity if I am presented with the username/password prompt.

I am at a bit of a loss what else I can try.

Thanks all

share|improve this question
    
Did you read the entire KB article you linked to? Specifically the part saying Note: This article applies only to ESX 4.x and earlier versions. In ESXi 4.1 and later versions, it is advised that you use Tech Support Mode. For more information, see Using Tech Support Mode in ESXi 4.1 and ESXi 5.0 (1017910). ? Is there a specific reason you're going against VMWare's recommendations? –  voretaq7 Dec 3 '12 at 6:31
    
Hi voretaq7. I sure did. Tech support mode is "Remote Support (SSH)" which (as I said) was enabled. I think you may have gotten mixed up by the terms used. –  Andrew White Dec 6 '12 at 1:04
    
D'OH! I must have skimmed too fast - I missed the part where you said you're getting the user/password prompt :-x Does local tech support mode work (let you log in)? If so verify that the SSH daemon is configured to allow root to log in (as you would on any nix host) - that *should be the default if I remember right but I'm not in front of an ESXi box to check... –  voretaq7 Dec 6 '12 at 2:40
    
No worries :). Unfortunately I can't test local as the machine is remote. I'm logging in with another user that's in the root group however, not as root. –  Andrew White Dec 6 '12 at 3:44
    
AH! That might be your problem - I think you have to go through some gyrations to make regular users work (invalid shell by default or something similar). I'll take a look tomorrow when I'm in the office –  voretaq7 Dec 6 '12 at 4:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.