Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My problem is that whenever my server sends emails, the sender field gets overwritten.

From: should be: Web Site Name <admin@mywebsite.com>

But email is delivered to the address from:

World Wide Web Owner <www@mywebsite.com>

Or while sending the emails from the root in the SSH:

Charlie & <root@mywebsite.com>

My /etc/ssmtp/ssmtp.conf configuration file content:

root=postmaster@mywebsite.com
mailhub=ssl0.ovh.net:465

rewriteDomain=mywebsite.com
hostname=mywebsite.com
realname = "Web Site Name"

AuthUser=postmaster%mywebsite.com
AuthPass=removed
UseTLS=YES

How can I instruct ssmtp not to change From: fields in emails? Or just define the From: anywhere?

When I add FromLineOverride=YES into the ssmtp.conf the server doesnt want to send emails anymore (email with set Form field).

share|improve this question

1 Answer 1

up vote 1 down vote accepted
FromLineOverride=YES

Should do the trick. Are you sure you are setting the From header correctly inside your mail sending code?

share|improve this answer
    
Terrible misstake. Thank you :P –  Scott Dec 3 '12 at 22:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.