Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On Ubuntu 12.04 I installed BIND9 via apt-get install.

I configure the server in a very simple way and it works in name resolution. Now I'm curious to read (if it's possible) its cache.

Reading the rndc manpage I tried to use the rndc flush view command, but it says

rndc: `flush` failed: not found

while if I run simply rndc flush it works.

So, first of all, where I can find the BIND9 cache file?

And then, why rndc flush view fails?

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

You seem to be asking two different questions.

For the first, the cache is held only in RAM. However you can view it with rndc dumpdb --cache which will be saved (on Debian and Ubuntu) by default to /var/cache/bind/.

For the second, I think that perhaps you don't know what a view is with regard to bind.

A view is an alternate zone presented to a subset of clients. For example, if you have a private and public network you might create a public only view of your zone for external clients while internal clients will have a view for public and private networks. You can only flush a named view that is configured in named.conf (or any included files).

A view is not the same thing as a zone, and you can't individually flush zones.

share|improve this answer
    
Thank you for the explanation. But after I run rndc dumpdb --cache I can't find the file in /var/cache/bind. This folder contains managed-keys.bind and managed-keys.bind.jnl –  JustTrying Dec 3 '12 at 9:37
    
Look in /etc/bind/* for the directory directive. This will be the location where it gets saved. And the user bind must have write permission for that directory. –  bahamat Dec 3 '12 at 9:40
    
I know this is an OT, but I have directory "/etc/bind/"; and I also run chown root.bind /etc/bind/, but the dumpdb file doesn't yet exist. –  JustTrying Dec 3 '12 at 10:04
1  
You also need to make sure that the group permission is +w for /etc/bind. –  bahamat Dec 3 '12 at 19:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.