Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My specific use case is that I have a NetApp CIFS storage that's in the domain, say, intranet. But I also have one hyper-v host that's not in the domain. I can't allow it into the domain, but I need to create guests whose VHD is on the storage.

How can I achieve this? When I simply connect to a CIFS share and create a VHD there, it works, but when I try to add that VHD to the virtual machine, I get a "Failed to set folder permissions" error - probably due to folder ownership being in the domain admin.

Is there a way around this? So both domain and non-domain users use the same directory?

share|improve this question
Are you using Server 2012? Technically Hyper-V in previous versions doesn't support CIFS. iSCSI might be a better option for your use case. – Eric Nicholson Dec 3 '12 at 16:20
Like Eric Nicholson suggested in the comment, I ended up using iSCSI for this use case. – Zlatko Dec 3 '12 at 17:51
@EricNicholson: Why not expand on this and add it as an answer? – Scott Pack Dec 3 '12 at 19:08
up vote 1 down vote accepted

Are you using Server 2012? Technically Hyper-V in previous versions doesn't support CIFS/SMB because the protocol's sessions aren't really fault-tolerant. iSCSI is probably a better option for your use case and very well supported on NetApp.

If you are interested in using SMB 3.0 with Hyper-V in Server 2012 you can join the NetApp beta program here:

Also to answer the original question, you can add users/passwords directly to Data ONTAP that are not part of a domain. Then you'd need to connect as "MyStorage\SomeUser". I doubt that's possible with Hyper-V and you'd be unsupported by both NetApp & Microsoft even if it worked.

share|improve this answer
As requested by Scott. Cheers! – Eric Nicholson Dec 4 '12 at 13:27

In order to put VHD files on SMB shares, the SMB server must offer SMB 3.0 (this is the revision of the protocol) and both the Hyper-V host and the SMB server must be part of the same Active Directory, so that the VHD file permissions can be set meaningfully.

I suspect that the first part isn't true in your case. You've stated explicitly that you're not willing to make the second part true. You should probably look for another storage solution.

share|improve this answer
Unfortunately, another storage solution isn't the answer. Thank you for the explanation, though. – Zlatko Dec 3 '12 at 17:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.