Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have an Isilon cluster with 8 IQ 12000x nodes which exports storage via several NFS shares for a handful of Linux and Solaris clients.

There is a Linux system that has one of these NFS filesystems mounted. I/O to this filesystem is moderately heavy from the Linux system. Every 3-4 weeks (it's not on any kind of discernible schedule, and sometimes is more/less frequent than this), we notice that all activity ceases on this NFS mount (the process hangs, as if the network stopped working so process is stuck in uninterruptible sleep) - 30 minutes later, the share recovers and things continue to work normally. The kernel log from the affected machine is as follows:

Dec  3 10:07:29 redacted kernel: [8710020.871993] nfs: server nfs-redacted not responding, still trying
Dec  3 10:37:17 redacted kernel: [8711805.966130] nfs: server nfs-redacted OK

relevant /etc/fstab line:

nfs-redacted:/ifs/nfs/export_data/shared/...redacted... /data nfs defaults 0 0

I've checked to see if there are any scheduled processes e.g. cron jobs, Isilon related functions e.g. snapshots, etc that might be causing these hangups but I can't seem to find anything. I'm also not aware of any network related issues or maintenance that would cause this. All of the lockups last almost exactly 30 minutes per the kernel logs.

Perhaps someone has some suggestions I could try? (I considered a soft mount to avoid the problems associated with processes accessing the filesystem hanging; however am wary of the corruption that could result and it would not really solve the underlying issue anyway).

share|improve this question
Is nfs-redacted in the Linux log an IP address of the Isilon node or a SmartConnect hostname? Could you log onto isilon nodes to check for anything suspicious in the logs? Most importantly, did you get any response from Isilon support? – Dmitri Chubarov Dec 4 '12 at 7:15
maybe modify the min/max rpc threads? – MaQleod Jan 29 '13 at 20:08
Does altering your mount settings help? rsize=32768,wsize=32768,timeo=14,intr may be of assistance for you – Nick Sep 10 '13 at 14:25

Check your MTU values are correct all the way through your wiring topology. If your access layer client is set to 9000, and it's going through a switch. Make sure the switch can handle larger MTU sizes.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.