Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Is there any way to get nginx running on port 80 on a windows 2003 server? It seems that the http.sys service is running on port 80 which is the new "preferred way" for a web server to run on windows however nginx and apache don't yet use this. Is there an easy way to stop this?

When I try and bind to port80 i get the following:

nginx: [emerg] bind() to 0.0.0.0:80 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)

netstat shows

Proto  Local Address          Foreign Address        State           PID
TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       4

and that pid is

C:\nginx-1.2.5>tasklist /svc /FI "PID eq 4"

Image Name                     PID Services
========================= ======== ============================================
System                           4 N/A
share|improve this question
1  
For me it was Skype (!) as suggested in this [other question.][1] [1]: serverfault.com/questions/478150/… –  Tom Sep 12 '14 at 12:44
    
Windows Web Server (IIS) may also cause this issue so try running: 'net stop WAS' to stop the service. Sometimes you may also need to run: 'net start W3SVC'. Note: Run cmd as admin. –  Tom Hagen Jun 26 at 18:30

1 Answer 1

up vote 2 down vote accepted

Turns out it was not http.sys and was in fact Sql Server Reporting Services... Disabled them and it was good to go.

share|improve this answer
    
You can accept this as answer now. –  Cees Timmerman Jun 16 at 12:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.