Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My hosting service has just provided my 2 IP addresses, gateway and a Nameserver but in CentOS's rescue mode, I need to enable networking which has prefix field also. I have no idea what to fill in ipv4 field after '/'. Please help me with this.

error

share|improve this question
    
tried filling /24 which resulted an error –  Gursimran Singh Dec 3 '12 at 22:21
    
I'd take this up with your hosting provider as they should be able to easily help you out on this as without the specific information provided I would not be able to help. (could be subnetted, etc....) –  mdpc Dec 3 '12 at 22:42

1 Answer 1

up vote 1 down vote accepted

Manually setting an IP is done with a command like ifconfig eth0 10.1.1.1 netmask 255.255.255.0 or ip addr add dev eth0 10.1.1.1/24 depending on if you want to use ifconfig or iproute2.

The prefix you received is translated into the netmask value.

share|improve this answer
    
having a look at screenshot 'll give you idea about where I am stuck at. i.imgur.com/4Ox6S.png –  Gursimran Singh Dec 3 '12 at 22:35
    
You put in your netmask. If it is 255.255.255.0 then you put in 24. If the netmask is something else you can easily find a subnet calculator to help. –  Zoredache Dec 3 '12 at 22:47
    
My netmask is 255.255.255.0 and I am filling in 24 only but it is still not working. –  Gursimran Singh Dec 3 '12 at 22:54
    
Be more specific. What exactly do you mean by not working. Do you get an error from the input box, or does the network not work? –  Zoredache Dec 3 '12 at 22:57
    
I am getting error after inputting these details that the details that I am unable to set up network interface eth0 –  Gursimran Singh Dec 3 '12 at 23:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.