Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I had this working at some point with TFS 2010 and IIS 7 but didn't save the settings when I upgraded to Windows 8.

Basically, I have a TFS 2012 server running. Everything works fine when I am using http://localhost:8080/tfs to access the server. I can login with both my Microsoft account as well as a local administrator account.

Now, I'm trying to make the TFS server publicly accessible (I use DynDNS). In IIS, I edited the bindings for the TFS website to accept connections on myusername.dyndns.org:8080. Now, when I go to http://myusername.dyndns.org:8080/tfs from a browser or from VS 2012, it prompts the login dialog but I am not able to authenticate on any account.

I'm sure I'm missing steps but setting up TFS for access on a custom hostname seems to be something no one has written about on the internet (except the guide I used to set it up with TFS 2010 which I am now unable to find).

Anyone have steps for me?

share|improve this question

Open the Team Foundation Server admin Console and use the "Change server Urls" option to change the server's bindings. That should automatically update the IIS website as well:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.