Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a default WordPress install Running on EC2/RDS with NGINX & PHP5-FPM on http://seolinktools.com, and spent most of the day configuring it. It's lightning fast.

I went to install W3 Total Cache, which works which would make it easy to place static files in a Varnish Cache / CDN so I figured i'd give it a try.

When I tried to use CloudFront, it was grayed out, and after some research, I found out it was because CURL PHP wasn't enabled. I then ran the command

apt-get install curl libcurl3 libcurl3-dev php5-curl and everything ran. I then restarted Nginx. Unfortunately, it doesn't look like it solved my problem.

I wanted to know if anyone here could give me a hand on this, i'm lost.

Thanks Zach

share|improve this question
It's php-fpm you need to restart. –  Michael Hampton Dec 5 '12 at 1:13
Michael, this is correct. However, since it's Debian/Ubuntu, the correct command would be service php5-fpm restart –  Panagiotis PJ Papadomitsos Dec 5 '12 at 23:54
Damn, I did the restart and it crashed php5-fpm, it fails to start now. Any ideas as to why? –  Zach Russell Dec 7 '12 at 5:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.