Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

After I upgraded from kernel 2.6.18 to 3.5.3 modeswitch started not to work for me. Although lsusb shows my usb modem, usb_modeswitch does not switch it. My system information is like below. I ran lsusb, dmesg, usb-devices and usb_modeswitch their output is like below. usb_modeswitch instead of switching my modem it says "No devices in default mode found. Nothing to do. Bye.". Can you offer a solution?

Kernel: Linux 3.5.3
usb_modeswitch: 1.2.3-1
usb_modeswitch-data: 20120120-1
usbutils: 006-1
libusb: 1.0.8-0.1



root@localhost$ lsusb
Bus 002 Device 029: ID 12d1:1446 Huawei Technologies Co., Ltd. 



root@localhost$ dmesg
[70112.477080] usb 2-1.4: new high-speed USB device number 30 using ehci_hcd
[70112.567757] scsi49 : usb-storage 2-1.4:1.0
[70112.567842] scsi50 : usb-storage 2-1.4:1.1
[70113.571433] scsi 49:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
[70113.572304] scsi 50:0:0:0: Direct-Access HUAWEI TF CARD Storage PQ: 0 ANSI: 2
[70113.574169] sr0: scsi-1 drive
[70113.574223] sr 49:0:0:0: Attached scsi CD-ROM sr0
[70113.574250] sr 49:0:0:0: Attached scsi generic sg1 type 5
[70113.574350] sd 50:0:0:0: Attached scsi generic sg2 type 0
[70113.577173] sd 50:0:0:0: [sdb] Attached SCSI removable disk



root@localhost$ usb-devices
T: Bus=02 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#= 30 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=12d1 ProdID=1446 Rev=00.00
S: Manufacturer=Huawei Technologies
S: Product=HUAWEI Mobile
C: #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=500mA
I: If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
I: If#= 1 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage



root@localhost$ cat /etc/usb_modeswitch.d/12d1\:1446
# Huawei, newer modems

TargetVendor= 0x12d1
TargetProductList="1001,1406,140b,140c,1412,141b,1433,1436,14ac,1506"

MessageContent="55534243123456780000000000000011062000000100000000000000000000"



root@localhost$ usb_modeswitch -c /etc/usb_modeswitch.d/12d1:1446 -v 12d1 -p 1446 -W

* usb_modeswitch: handle USB devices with multiple modes
* Version 1.2.3 (C) Josua Dietze 2012
* Based on libusb0 (0.1.12 and above)

! PLEASE REPORT NEW CONFIGURATIONS !

DefaultVendor= 0x12d1
DefaultProduct= 0x1446
TargetVendor= 0x12d1
TargetProduct= not set
TargetClass= not set
TargetProductList="1001,1406,140b,140c,1412,141b,1433,1436,14ac,1506"

DetachStorageOnly=0
HuaweiMode=0
SierraMode=0
SonyMode=0
QisdaMode=0
GCTMode=0
KobilMode=0
SequansMode=0
MobileActionMode=0
CiscoMode=0
MessageEndpoint= not set
MessageContent="55534243123456780000000000000011062000000100000000000000000000"
NeedResponse=0
ResponseEndpoint= not set

InquireDevice enabled (default)
Success check disabled
System integration mode disabled


usb_set_debug: Setting debugging level to 15 (on)
usb_os_find_busses: Skipping non bus directory devices
usb_os_find_busses: Skipping non bus directory drivers
usb_os_find_busses: Skipping non bus directory uevent
usb_os_find_busses: Skipping non bus directory drivers_probe
usb_os_find_busses: Skipping non bus directory drivers_autoprobe
Looking for target devices ...
No devices in target mode or class found
Looking for default devices ...
No devices in default mode found. Nothing to do. Bye.

Thanks in advance.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.