Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have recently began adding XPe thin clients to our domain in preperation for a new citrix environment.

One thing that has been picked up on in testing is that they appear slow to boot. The issue manifest's it's self as the classic "Applying Computer Settings..." screen we are all used to seeing.

After digging into the issue it appears the DHCP Client service is taking some time to load on boot, this varies but I would estimate it can take around 1 minute in some cases.

I've eliminated the classic issues, DHCP is responding correctly and in quick time. DNS is not the cause and GPO's are applying promptly.

A simple workaround is to assign the client a static IP which work's great so the TCP/IP servies are obviously firing up quickly, just not DHCP Client.

Does anyone have any idea's on how I may be able to improve the service start time? Keen to find a better solution before I get my arm twisted into setting up 250 thin clients with static addressing!


Sorry, I omitted this from the opening post.

Portfast doesn't solve the issue but it does however move it.

Now, the applying computer setting appears after the user logs in, if they do it before its finished sorting its self out in the background.

share|improve this question
    
Enable portfast (or the equivalent) on the switch ports that the clients are connected to. –  joeqwerty Dec 5 '12 at 15:45
    
temporarily disable Spanning Tree Protocol on any in-line switches as a test. –  user148432 Dec 5 '12 at 18:08
    
@Ryan You appear to have wound up with two accounts somehow - I've merged them and converted your post with extra info to an edit. You may want to make sure your account is properly registered & associated with an OpenID so you can come back and edit this question in the future if the need arises :-) –  voretaq7 Dec 5 '12 at 18:40
    
Thanks, I created the question at work and replied on my phone, probably why I have two. –  Ryan Dec 5 '12 at 18:47
    
I'll try disabling spanning tree on the port when I'm back in on Friday. I am curious though, have you seen similar problems with spanning tree on? –  Ryan Dec 5 '12 at 18:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.