Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Per a recent question I recently configured both my HP (2x 2900) and Cisco (1x 3750) hardware to use MSTP for interoperability. I thought this was functional until I applied the change to the third device (HP switch 1 below) at which time the spanning tree root started flapping causing performance issues (5% packet loss) between my two HP switches. I'm not sure why.

HP Switch 1 A4 connected to Cisco 1/0/1. HP Switch 2 B2 connected to Cisco 2/0/1. HP Switch 1 A2 connected to HP Switch 2 A1. I'd prefer the Cisco stack to act as the root.

EDIT:


There is one specific line - 'spanning-tree 1 path-cost 500000' in the HP switch 2 that I didn't add and was preexisting. I'm not sure if it could have the kind of impact that I'm describing. I'm more a security and monitoring guy then networking.


EDIT 2:


I'm starting to believe the problem lies in the fact that the value for my MST 0 instance on the Cisco is still at the default 32768. I worked up a diagram: Spanning Tree MAC Associations This is based on every show command I could find for STP. I'll make this change after hours and see if it helps.


Cisco 3750 Config:

version 12.2

spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
 name mstp
 revision 1
 instance 1 vlan 1, 40, 70, 100, 250
spanning-tree mst 1 priority 0
vlan internal allocation policy ascending

interface TenGigabitEthernet1/1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface TenGigabitEthernet2/1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 192.168.100.253 255.255.255.0
!

Cisco 3750 show spanning tree:

show spanning-tree

MST0
  Spanning tree enabled protocol mstp
  Root ID    Priority    32768
             Address     0004.ea84.5f80
             Cost        200000
             Port        53 (TenGigabitEthernet1/1/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768  (priority 32768 sys-id-ext 0)
             Address     a44c.11a6.7c80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te1/1/1             Root FWD 2000      128.53   P2p


MST1
  Spanning tree enabled protocol mstp
  Root ID    Priority    1
             Address     a44c.11a6.7c80
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    1      (priority 0 sys-id-ext 1)
             Address     a44c.11a6.7c80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te1/1/1             Desg FWD 2000      128.53   P2p

Cisco 3750 show logging:

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

HP Switch 1:

; J9049A Configuration Editor; Created on release #T.13.71
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-8,10,13-16,18-23,A1-A4
   ip address 100.100.100.17 255.255.255.0
   no untagged 9,11-12,17,24
   exit
vlan 100
   name "192.168.100"
   untagged 9,11-12,17,24
   tagged 1-8,10,13-16,18-23,A1-A4
   no ip address
   exit
vlan 21
   name "Users_2"
   tagged 1,A1-A4
   no ip address
   exit
vlan 40
   name "Cafe"
   tagged 1,4,7,A1-A4
   no ip address
   exit
vlan 250
   name "Firewall"
   tagged 1,4,7,A1-A4
   no ip address
   exit
vlan 70
   name "DMZ"
   tagged 1,4,7-8,13,A1-A4
   no ip address
   exit
spanning-tree
spanning-tree config-name "mstp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 40 70 100 250
password manager
password operator

HP Switch 1 show spanning tree:

 show spanning-tree

 Multiple Spanning Tree (MST) Information

  STP Enabled   : Yes
  Force Version : MSTP-operation
  IST Mapped VLANs : 2-39,41-69,71-99,101-249,251-4094
  Switch MAC Address : 0021f7-126580
  Switch Priority    : 32768
  Max Age  : 20
  Max Hops : 20
  Forward Delay : 15

  Topology Change Count  : 363,490
  Time Since Last Change : 14 hours

  CST Root MAC Address : 0004ea-845f80
  CST Root Priority    : 32768
  CST Root Path Cost   : 200000
  CST Root Port        : 1

  IST Regional Root MAC Address : 0021f7-126580
  IST Regional Root Priority    : 32768
  IST Regional Root Path Cost   : 0
  IST Remaining Hops            : 20

  Root Guard Ports     :
  TCN Guard Ports      :
  BPDU Protected Ports :
  BPDU Filtered Ports  :
  PVST Protected Ports :
  PVST Filtered Ports  :

                  |           Prio            | Designated    Hello
  Port  Type      | Cost      rity State      | Bridge        Time PtP Edge
  ----- --------- + --------- ---- ---------- + ------------- ---- --- ----
  A1              | Auto      128  Disabled   |
  A2    10GbE-CX4 | 2000      128  Forwarding | 0021f7-126580 2    Yes No
  A3    10GbE-CX4 | Auto      128  Disabled   |
  A4    10GbE-SR  | Auto      128  Disabled   |

HP Switch 1 Logging: I removed the date / time fields since they are inaccurate (no NTP configured on these switches)

00839 stp: MSTI 1 Root changed from 0:a44c11-a67c80 to 32768:0021f7-126580
00839 stp: MSTI 1 Root changed from 32768:0021f7-126580 to 0:a44c11-a67c80
00842 stp: MSTI 1 starved for an MSTI Msg Rx on port A4 from 0:a44c11-a67c80
00839 stp: MSTI 1 Root changed from 0:a44c11-a67c80 to 32768:0021f7-126580
00839 stp: MSTI 1 Root changed from 32768:0021f7-126580 to 0:a44c11-a67c80
00839 stp: MSTI 1 Root changed from 0:a44c11-a67c80 to ...

HP Switch 2 Configuration:

; J9146A Configuration Editor; Created on release #W.14.49

vlan 1
   name "DEFAULT_VLAN"
   untagged 1,3-17,21-24,A1-A2,B2
   ip address 100.100.100.36 255.255.255.0
   no untagged 2,18-20,B1
   exit
vlan 100
   name "192.168.100"
   untagged 2,18-20
   tagged 1,3-17,21-24,A1-A2,B1-B2
   no ip address
   exit
vlan 21
   name "Users_2"
   tagged 1,A1-A2,B2
   no ip address
   exit
vlan 40
   name "Cafe"
   tagged 1,13-14,16,A1-A2,B2
   no ip address
   exit
vlan 250
   name "Firewall"
   tagged 1,13-14,16,A1-A2,B2
   no ip address
   exit
vlan 70
   name "DMZ"
   tagged 1,13-14,16,A1-A2,B2
   no ip address
   exit
logging 192.168.100.18
spanning-tree
spanning-tree 1 path-cost 500000
spanning-tree config-name "mstp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 40 70 100 250

HP Switch 2 Spanning Tree:

show spanning-tree

 Multiple Spanning Tree (MST) Information

  STP Enabled   : Yes
  Force Version : MSTP-operation
  IST Mapped VLANs : 2-39,41-69,71-99,101-249,251-4094
  Switch MAC Address : 0024a8-cd6000
  Switch Priority    : 32768
  Max Age  : 20
  Max Hops : 20
  Forward Delay : 15

  Topology Change Count  : 21,793
  Time Since Last Change : 14 hours

  CST Root MAC Address : 0004ea-845f80
  CST Root Priority    : 32768
  CST Root Path Cost   : 200000
  CST Root Port        : A1

  IST Regional Root MAC Address : 0021f7-126580
  IST Regional Root Priority    : 32768
  IST Regional Root Path Cost   : 2000
  IST Remaining Hops            : 19

  Root Guard Ports     :
  TCN Guard Ports      :
  BPDU Protected Ports :
  BPDU Filtered Ports  :
  PVST Protected Ports :
  PVST Filtered Ports  :

                  |           Prio            | Designated    Hello
  Port  Type      | Cost      rity State      | Bridge        Time PtP Edge
  ----- --------- + --------- ---- ---------- + ------------- ---- --- ----
  A1    10GbE-CX4 | 2000      128  Forwarding | 0021f7-126580 2    Yes No
  A2    10GbE-CX4 | Auto      128  Disabled   |
  B1    SFP+SR    | 2000      128  Forwarding | 0024a8-cd6000 2    Yes No
  B2              | Auto      128  Disabled   |

HP Switch 2 Logging: I removed the date / time fields since they are inaccurate (no NTP configured on these switches)

00839 stp: CST Root changed from 32768:0021f7-126580 to 32768:0004ea-845f80
00839 stp: IST Root changed from 32768:0021f7-126580 to 32768:0024a8-cd6000
00839 stp: CST Root changed from 32768:0004ea-845f80 to 32768:0024a8-cd6000
00839 stp: CST Root changed from 32768:0024a8-cd6000 to 32768:0004ea-845f80
00839 stp: CST Root changed from 32768:0004ea-845f80 to 32768:0024a8-cd6000
00435 ports: port B1 is Blocked by STP
00839 stp: CST Root changed from 32768:0024a8-cd6000 to 32768:0021f7-126580
00839 stp: IST Root changed from 32768:0024a8-cd6000 to 32768:0021f7-126580
00839 stp: CST Root changed from 32768:0021f7-126580 to 32768:0004ea-845f80
share|improve this question

2 Answers 2

Can you change the MST instance number to 0? I think this may be causing your issue, MST runs instance 0 by default so you have created two instances, instance 1 with the vlans you have mapped and instance 0 with all the others. judging by your Cisco config you should only need one instance:

spanning-tree mst configuration
 name mstp
 revision 1
 instance 0 vlan 1, 40, 70, 100, 250
 spanning-tree mst 0 root primary

Its strange that your root is flapping but you have only set the priority for instance 1 not 0. Move it all to instance 0 and also set the priority of MST instance 0 on the HP switches to higher than the default. Then the root will always be the 3750 as long as its on the network.

On the HP switches:

spanning-tree
spanning-tree config-name "mstp"
spanning-tree config-revision 1
spanning-tree instance 0 vlan 1 40 70 100 250
spanning-tree priority 36864

The Spanning tree path cost command was configured probably to stop HP2 from becoming the root:

Syntax: spanning-tree < port-list > path-cost < auto | 1..200000000 >

Assigns an individual port cost that the switch uses to determine which ports are forwarding ports in a given spanning tree. In the default configuration ( auto ) the switch determines a port’s path cost by the port’s type: –

10 Mbps: 2000000 –

100 Mbps: 200000 –

1 Gbps: 20000

Refer to “Note on Path Cost” on page 4-17 for information on compatibility with devices running 802.1D STP for the path cost values (Default: Auto).

From the HP Advanced Traffic management guide page 138. If you didn't add the path cost statement I would remove it and just set the bridge priority higher on the switch you want to be the root. If thats the Cisco then you are already set with my commands.

share|improve this answer
up vote 1 down vote accepted

Wow.. After all the research it turns out all I was missing was setting the MST 0 instance value to a lower value than the default. Once I set it to 4096 all the show spanning tree configs started functioning as expected showing the Cisco macs as the root.

GerryEgan's solution would work in since it also would have changed the MST 0 instance to a lower value. however I'd eventually like to be able to use both 10 gig links, one for VLAN 1 and one for VLAN 100. This general setup was roughed out with that final goal in mind. I didn't include it in the question since it didn't really pertain - I was desperate for any solution.

In summary to configure this setup I used:

Cisco 3750

spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
 name mstp
 revision 1
 instance 1 vlan 1, 40, 70, 100, 250
spanning-tree mst 1 priority 0
spanning-tree mst 0 priority 4096

HP Switches

spanning-tree
spanning-tree config-name "mstp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 40 70 100 250
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.