Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This error is logged once I create a website:

The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80/ for site 6. The necessary network binding may already be in use. The site has been disabled. The data field contains the error number.

I followed this link but there is no ListenOnlyList, instead I saw UrlAclInfo which contains this:

enter image description here

C:\Users\Administrator>netstat -ano | find ":80" |find /i "listen"
  TCP    0.0.0.0:80             0.0.0.0:0              LISTENING       4
  TCP    [::]:80                [::]:0                 LISTENING       4

4 is the pid number of System process.

Any ideas to fix this?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

As stated here Un-Install Microsoft Web deploy and then Re-Install it using command line with these parameters:

msiexec /I <msi_filename> /passive ADDLOCAL=ALL LISTENURL=http://+:8080/MsDeployAgentService2/
share|improve this answer

Check that no existing website is using a binding without a host header on 0.0.0.0 ("All Unassigned").


If that's not the case, figure out what process has binded *:80 on your machine by issuing:

netstat -ano | find ":80" |find /i "listen"

That will show you the processes listening on :80, the last number in each string is the Process ID that created the given binding

To find a process by its PID, do the following:

  • Open Task Manager (Run -> taskmgr)
  • Go to the "Processes" tab
  • Click the "Show processes from all users" button in the bottom. This will enable you to see all processes(*)
  • Select View -> Select Columns in the menu
  • Be sure to have the "PID (Process ID)" checkbox checked
  • Press "OK"

This is the process obstructing your web site from registering its binding correctly

(*) PROTIP: Pressing the "Show processes from all users" button forces the console to attempt to elevate its privileges, effectively yielding the same call as "Run as administrator" in right-click context menus.
If Task Manager ever returns "Access is denied", "Access denied", error code 5 or returns nothing when sending messages to other users on a computer, simply press the button and you'll have all your permissions and privileges

share|improve this answer
    
Thank you but No, there is just a default website on *:80 and if I create another website it will log this error. –  Mario Dec 7 '12 at 22:55
    
Thanks again, I edited my question and added the result. It's System process that's holding 0.0.0.0:80. I don't think I can stop this process. –  Mario Dec 8 '12 at 6:54
    
I found out that Web Deployment Agent Service and World Wide Web Publishing Service are both using this port. so does this help? –  Mario Dec 8 '12 at 7:32

For me, it was Skype who uses port 80.

So uncheck Skype / Options / Advanced / Connection / Use port 80 and 443 as alternatives for incomming connections.

Now exit Skype, run it again. Everything should work from now.

share|improve this answer
    
Also true of the Skype 'Metro/Modern' app, except there's no obvious option to configure which port it uses –  David Gardiner Aug 29 at 5:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.