Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to enable an SMB share on Solaris 11.1 x64 My steps:

  1. pkg install service/filesystem/smb
  2. svcadm enable -r smb/server
  3. echo "other password required nowarn" >> /etc/pam.conf
  4. useradd public
  5. smbadm enable-user public
  6. zfs set share=name=fs1,path=/rpool/fs1,prot=smb rpool/fs1
  7. zfs set sharesmb=on rpool/fs1
  8. passwd -r files public

Step 8 failes: It is not possible to enter a password, output is:

solaris> passwd -r files public

Please try again

Please try again
Permission denied

If I uncomment the new line in pam.conf, it is possible to change the password. Nevertheless, it is not possible to access the share from Windows 7. The Solaris machine is reachable with ping.

Access with another SMB enabled user is denied too.

share|improve this question
up vote 0 down vote accepted

Hit the same problem myself, reading the docs the PAM configuration has been split off into a directory and sub-files, like linux if your familiar with that?

To resolve the problem remove the line from the /etc/pam.conf file and add to the /etc/pam.d/other file as follows...

# echo "password required    nowarn" >> /etc/pam.d/other

You should then be able to set the password for 'public'

IMHO the Oracle documentation for Solaris 11 is way better than Sun ever produced, I found the answer on this page...

share|improve this answer
I would suggest editing the files with an editor, not echoing stuff and appending it to the end of the file. With the technique you're suggesting there's no way to know what's in the file already, and you lose the ability to properly match formatting, whitespace, etc. – voretaq7 Dec 12 '12 at 2:12
This answer solved my problem. And of course, i used an editor to add the line. Thx – websta Dec 17 '12 at 16:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.