Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.
<<The configuration of your mail servers and your DNS are not ok! The report of the test is:

    mail.mydomain.com. -> mydomain.com -> 78.47.63.148 -> static.148.63.47.78.clients.your-server.de

Spam recognition software and RFC821 4.3 (also RFC2821 4.3.1) state that the hostname given in the SMTP greeting MUST have an A record pointing back to the same server.>>

I have a A Record that points mail.mydomain.com to 78.47.63.148 (which is my given ip address for my vps) All other records are fine, so what's wrong and what record should I create to make it right? Thanks

share|improve this question

1 Answer 1

If your server identifies itself as mail.mydomain.com in its SMTP greeting then the reverse DNS for your ip needs to be mail.mydomain.com. At the moment it's that static.xxx name.

You'll need to get your provider to change your reverse DNS or change you mail server to identify itself as static.148.63.47.78.clients.your-server.de. That static name should also have an A record pointing to the IP if you change the greeting, which it probably already does.

share|improve this answer
    
identify itself as "static.148.63.47.78.clients.your-server.de" is a bad idea, many spamfilters would block that due to a generic rDNS HELO. changing the reverse DNS to mail.mydomain.com is the only option that will make all other servers happy. –  Gryphius Dec 10 '12 at 5:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.