Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently set up folder redirection for my user profile in a domain.

For now, I've redirected AppData, Desktop, Pictures, Documents and Favorites. So far, so good. But now I've noticed a quite disturbing side effect of the whole thing.

Whenever I click any of my pinned elements on the task bar, I get the following warning:

enter image description here

The shortcuts get synced as well and are no longer trusted. They're located at

\\DFS\UserData\Profiles\OliverSalzburg\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar

That seems like it could be a problem when rolling it out to the whole company.

share|improve this question
Try adding the DFS namespace and the individual servers that host the DFS shares to the Intranet zone in IE. To solve this organization-wide, that can be set via group policy. – Ryan Ries Dec 10 '12 at 22:33
@RyanRies: I've set that up through GP, but the result is still the same and I'm uncertain how to verify if the zones are actually updated. The dialogs in IE are greyed out and list no URLs at all. – Oliver Salzburg Dec 11 '12 at 14:43
up vote 2 down vote accepted

Thanks to Ryan's comment I was able to resolve this issue by adding the DFS namespace to the IE Intranet zone. I also added the name of the actual storage server behind it, but I have not confirmed if that is actually required.

Initially I set up a GPO to add the namespace to the intranet zone on a computer level through the Site to Zone Assignment List found at:

Computer Configuration → Administrative Templates → Windows Components → Internet Explorer → Internet Control Panel → Security Page.

Additionally, I activated the policy Security Zones: Use Only Machine in the hopes that that would be sufficient to resolve the issue. However, that did not have the desired effect.

Only after applying the same Site to Zone Assignment List on a user level was the issue resolved. This is somewhat confusing, given that the Security Zones: Use Only Machine policy is still in effect.

Needless to say, I don't fully understand the solution, but it worked so far.

Additional Reading

I found these really helpful while working on the issue:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.