Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm not an expert on networks but have a small office on the 192.168.x.x. range which is managed by a vigor (2800) router. I have enabled the VPN dial-in option on the router so I can get to the server on 192.168.1.100 which works fine from my macbook when i'm NOT on a local network with that is on the 192.168.x.x range. e.g. works fine when I tether over my Android smartphone but when I try & connect when on my home network, it connects, I can access the router (192.168.1.1) but cannot access 192.168.1.100 - traceroute doesn't hop via 192.168.1.1

I have enabled "send all traffic over VPN connection but again, not joy... Feels like the osx platform isn't routing the traffic out to the vpn endpoint as the destination address is on the local subnet but expect it would be.

This work fine on a windows PC on the same home network.

Any thoughts on what the issue could be?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Sounds like an address space collision to me. As in, don't use the default address space that almost every home network/piece of SOHO gear in the world uses for your corporate network. So get your small office network off that address range, and onto a 10.[something].

To resolve the issue at your home, the quickest option is to change your home subnet to 172.[something] (172.16 through 172.31 are private addresses). I tend to use a 172.2x.x. subnet at home, since they're generally not used by a whole lot, whereas the lower 172 subnets are frequently used for VPNs.

share|improve this answer

As a first step in isolating your problem, look to the service order in the networking system preference pane. Since you report another home PC working, it's unlikely the problem is entirely on the server side of things (unless you have some odd setup that has defaults that cater to Microsoft OS).

Set Service Order

You can see that the VPN fall to the bottom of the list when you are not connected, so be sure to change these (click on the gear in the lower left of the preference window - immediately to the right of the + / - controls to change the network interfaces.

Also, since the networking stack on OS X is BSD based, you can use netstat and other unix network routing commands to inspect the routing table / default route that is set before and after connecting to the VPN.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.