Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Today (after turning on the server from an extended power outage) some clients are not able to get IP addresses. Some clients work just fine. Win 7 and XP doesnt seem to matter.

I have tried flushing dns, renew, disabling APIPA and even assigned a static IP. Even with the static IP it acts as if it isn't on a network. You can't ping anything. I have also tried resetting the TCPIP stack.

The clients that work can ping the DNS and DHCP servers fine.

Any suggestions?

Thanks

share|improve this question
3  
"even assigned a static IP" - Then it's not a DHCP problem. - "You can't ping anything" - This doesn't tell us anything about the problem. –  joeqwerty Dec 10 '12 at 19:29
2  
Sounds more like a physical issue, really. Are the clients who can not resolve on the same switch? –  cole Dec 10 '12 at 19:31
    
Indeed. Check the cables and adapters. Also check the switch ports. Do all interfaces show link up? Is your switch managed or unmanaged? Can you see Ethernet traffic in Wireshark? –  Ansgar Wiechers Dec 10 '12 at 19:33
add comment

2 Answers

up vote 3 down vote accepted

Based on your description it sounds a lot more like a network switch, bad cable, bad NIC sort of problem.

Are you sure that the switch came up correctly and that the ports are on the correct vLAN?

share|improve this answer
    
Thanks for the suggestions. It turned out it was one of the switches. Oddly the switch seemed to work fine on some of the ports...which is why I didn't further investigate. However after going back again and swapping cables around to the other switch I found it was indeed the switch. Odd never saw something like that happen. –  AdminAlive Dec 10 '12 at 22:09
add comment

I've eperienced something similiar before myself. To fix this I first assigned each network adapter an IP address from the DHCP scope which they belonged to (and also pointed each adapter towards the correct DNS server).

After these settings were applied I then went back in and reset the network adapter to automatically receieve an IP address (and DNS address) via DHCP and that worked for me.

Sounds strange I know but it did work for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.