Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have tried to remotely access two different servers on two different machines, one 2008 the other 2012, and have had zero luck with either machine.

I have followed the steps in: How to enable remote connections for SQL Server 2008?

  1. I went to the protocols for MSSQLServer and enabled TCP/IP making sure the dynamic port was blank and the IPALL TCP port is 1433.

  2. I checked the properties of the server and confirmed under Connections that remote connections to the server are allowed.

  3. I went to the firewall and added a rule allowing local port 1433 for all profiles. I even tested the connection with the firewall disabled.

None of these steps worked for either machine. I can see and access all the machines' shared files on the network. I'm not sure what to try next. This is my first time trying to setup a sql server. I appreciate any help or advice you can give me!

share|improve this question

1 Answer 1

You have to restart the SQL Server service in services.msc after making these changes for them to take effect. Restart them and try again. Also, if you're using a named instance instead of the default instance, make sure you include that in your connection string.

share|improve this answer
    
Thanks for the help! Neither option seemed to solve my problem though. I had restarted the computer previously. I just tried restarting the SQL server in Services with no luck. I am using "ComputerName\SQLEXPRESS" as the server name. –  Chris86 Dec 10 '12 at 21:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.