Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to setup squid 3.2.4, but I have not been able to get it working for remote users. Works fine locally. Unable to figure out what I am doing wrong...

http_port 3128 transparent ssl-bump generate-host-certificates=on dynamic_cert_mem_cache_size=4MB cert=/usr/share/ssl-cert/myCA.pem

refresh_pattern ^ftp:           1440    20%     10080
refresh_pattern ^gopher:        1440    0%      1440
refresh_pattern -i (/cgi-bin/|\?) 0     0%      0
refresh_pattern .               0       20%     4320

acl localnet src 10.0.0.0/8     # RFC 1918 possible internal network
acl localnet src 172.16.0.0/12  # RFC 1918 possible internal network
acl localnet src 192.168.0.0/16 # RFC 1918 possible internal network
acl localnet src fc00::/7       # RFC 4193 local private network range
acl localnet src fe80::/10      # RFC 4291 link-local (directly plugged) machines

acl SSL_ports port 443
acl Safe_ports port 80          # http
acl Safe_ports port 21          # ftp
acl Safe_ports port 443         # https
acl Safe_ports port 70          # gopher
acl Safe_ports port 210         # wais
acl Safe_ports port 1025-65535  # unregistered ports
acl Safe_ports port 280         # http-mgmt
acl Safe_ports port 488         # gss-http
acl Safe_ports port 591         # filemaker
acl Safe_ports port 777         # multiling http
acl CONNECT method CONNECT

http_access allow manager localhost
http_access deny manager
http_access deny !Safe_ports
http_access allow localhost
http_access allow localnet
http_access allow all

cache deny all

via off
forwarded_for off

header_access From deny all
header_access Server deny all
header_access WWW-Authenticate deny all
header_access Link deny all
header_access Cache-Control deny all
header_access Proxy-Connection deny all
header_access X-Cache deny all
header_access X-Cache-Lookup deny all
header_access Via deny all
header_access Forwarded-For deny all
header_access X-Forwarded-For deny all
header_access Pragma deny all
header_access Keep-Alive deny all

acl ip1 localip 1.1.1.90
acl ip2 localip 1.1.1.91
acl ip3 localip 1.1.1.92
acl ip4 localip 1.1.1.93
acl ip5 localip 1.1.1.94
tcp_outgoing_address 1.1.1.90 ip1
tcp_outgoing_address 1.1.1.91 ip2
tcp_outgoing_address 1.1.1.92 ip3
tcp_outgoing_address 1.1.1.93 ip4
tcp_outgoing_address 1.1.1.94 ip5
tcp_outgoing_address 1.1.1.90
share|improve this question
1  
It would be helpful if you included what troubleshooting steps you have done. Is remote traffic getting to the server? Check tcpdump. What is squid doing with the remote traffic? Turn on debug logging with debug_options ALL,9. –  Anton Cohen Dec 11 '12 at 0:52
    
figured it out, apparently squid was already installed using apt-get and I was trying to run 3.2 which you have to compile. –  Sean Dec 12 '12 at 6:46
add comment

1 Answer

does your squid-machine know the route to these "remote users"?

could you clarify what your local net is and what your remote users are? What issue at the remote users? Timeout? Forbidden?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.