Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to set up a Cisco SA520 to run DHCP on my network. I have a vendor provided switch, the Adtran 1234, and it provides DHCP for our phone systems on VLAN 200. I do not have access to the Adtran, but the vendor gave me a IP on port 1 for WAN and said port 2 should be for the "trust" side should go.

I did setup a mini lab where, Adtran 1 went to SA520 WAN port, and SA520 trust 1 went to my laptop. Everything worked fine, I could ping and get internet using the DHCP scope I put on the SA520.

I then unplugged my computer from SA520 trust 1 and plugged it into Adtran 2. I plugged my computer into Adtran 23 and I dont get DHCP or even a link light. If I restart my machine, I get a brief link and then it dies once the machine boots. I have tried several ports on the Adtran and none seem to work. Different cables as well.

However, when I plug a phone into the Adtran, the phone boot immediately and shows link.


share|improve this question
up vote 0 down vote accepted

Adtran 1234 is 10/100 and while all ports are set to auto, that was the issue. I solved this by setting the WAN port and trunk 1 on the SD520 to Full Duplex 100 and I got on once I set my MBP to Full Duplex 100.

I took it a step further, and didnt want to reconfigure all of my machines. So I tested auto on "trust" 1 for the SD520, set my computer back to auto, and I am still going strong. Even when one-wired off of the phone.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.