Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to get the debug version of httpd so I can use it in conjunction with gdb. I am having a hard time getting them, and they don't seem to be in the standard epel-debuginfo repository. What should I do?

> [root@buildbox-rhel6 ~]# debuginfo-install httpd
Loaded plugins: fastestmirror, presto
enabling epel-debuginfo
Loading mirror speeds from cached hostfile
epel-debuginfo/metalink                                                                              | 8.3 kB     00:00     
 * base: mirrors.cicku.me
 * epel: mirrors.kernel.org
 * epel-debuginfo: mirrors.kernel.org
 * extras: mirrors.arpnetworks.com
 * updates: linux.mirrors.es.net
epel-debuginfo                                                                                       | 3.1 kB     00:00     
epel-debuginfo/primary_db                                                                            | 487 kB     00:01     
Checking for new repos for mirrors
Could not find debuginfo for main pkg: httpd-2.2.15-15.el6.centos.1.x86_64
Could not find debuginfo pkg for dependency package apr-1.3.9-5.el6_2.x86_64
Could not find debuginfo pkg for dependency package apr-util-1.3.9-3.el6_0.1.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package db4-4.7.25-17.el6.x86_64
Could not find debuginfo pkg for dependency package expat-2.0.1-11.el6_2.x86_64
Could not find debuginfo pkg for dependency package openldap-2.4.23-26.el6_3.2.x86_64
Could not find debuginfo pkg for dependency package openldap-2.4.23-26.el6_3.2.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package pcre-7.8-4.el6.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package glibc-2.12-1.80.el6_3.6.x86_64
Could not find debuginfo pkg for dependency package libselinux-2.0.94-5.3.el6.x86_64
Could not find debuginfo pkg for dependency package zlib-1.2.3-27.el6.x86_64
No debuginfo packages available to install
share|improve this question

1 Answer 1

up vote 3 down vote accepted

It looks like debuginfo-install is only searching epel-debuginfo. httpd in not in EPEL. The httpd debuginfo is in a repo called 'debug'.

Enable debug repo:

debuginfo-install --enablerepo=debug httpd

If that doesn't work use yum:

yum --nogpgcheck --enablerepo=debug install httpd-debuginfo
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.