Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am accessing the built in SharePoint 2010 on SBS2011 via Microsoft Office Excel and Word (opening a file from WebDAV http file mapped drive in Explorer).

When saving a file, I get prompted from within Microsoft Office 2010 Word/Excel for credentials - entering the correct credentials just prompts the window again.

Clicking cancel allows me to go to My computer -> mapped drive and save the file.

I am able to browse the SharePoint site via Internet Explorer without an issue and I am not prompted for a password when doing so, I presume this means Windows authentication is working via the SharePoint URL being in the intranet list.

I have also check that the sharepoint url is in the trusted intranet sites list.

Anything else I should look in to?

share|improve this question

2 Answers 2

up vote 5 down vote accepted
+100

Have you tried using the following registry value? This usually works with integrated authentication (not basic/forms authentication).

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters  
Value: AuthForwardServerList  
Type: Multi-string  

Refer to the following document for more information:

Prompt for Credentials When Accessing FQDN Sites
http://support.microsoft.com/kb/943280

share|improve this answer
    
This will work. We deploy it via GPO here, since our Sharepoint site is a FQDN. +1 –  TheCleaner Jan 21 '13 at 13:57
    
Hi thanks for link can you please verify kb number as link doesnt work –  g18c Jan 24 '13 at 5:47
    
@g18c: It is 943280 –  Greg Askew Jan 24 '13 at 12:08

Here's something to try.

http://blogs.microsoft.co.il/blogs/choroshin/archive/2012/11/06/sharepoint-getting-authentication-login-prompt-when-trying-to-open-office-document-with-unique-permissions.aspx

The problem is in opening an Office document which is saved in SharePoint 2010:

  1. When a user has a "read" permission only to a specific document in a document library, but do not have any permissions in the document library level nor the site level.

  2. When he is accessing the document, he receives the "Download File" message with "Open" / "Save" / "Cancel" options.

  3. When clicking "Open", he is prompted with a user & password message. When clicking his correct user and password, the user & password message remains – nothing happens.

  4. Only when clicking "Cancel" in the user & password message, the document opens.

  5. Users who has read permissions in the document library level or the site level – manage to open the document successfully, meaning are not prompted with the user & password message after clicking "Open" (it opens the document).

There are 3 possible ways to solve this issue:

1. Add read only permission in the root of the site collection.

2. Deactivate the feature “ViewFormPagesLockDown”:

stsadm -o deactivatefeature -url http://SERVERNAME/sites/SITENAME -filename ViewFormPagesLockDown\feature.xml

3. Run the following script on your site collection, this will add permission level to the “Limited Access” Permission level that you have in that site collection.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.