Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've actually found the solution, but I'm trying to understand why it failed, and why my solution fixed the problem.

We have an application that uses forms authentication between a web server and sql server, web server runs server 2008, sql server runs 2008 r2, and sql server 2008.

In august the sql server was patched with .net 3.5.1, the web server was untouched, and the forms authentication continued to work.

1 week ago we virtualized the web server onto our vSphere server because of failing hardware. Afterwards the form authentication failed with event code 4005, detail code 50201, The ticket supplied was invalid (on the sql server). In fact the sql server started generating Schannel errors and began blue screening 3-4 times a day.

At this point I touched the sql server for the first time(ever), the errors were non specific, any reference to them I could find had to do with either zone alarm(which we don't run), or memory errors. So I applied service pack 1, which stopped the blue screening, but did not fix the forms authentication.

At this point we had a work around, so we put it on the back burner while we completed another project, and I was able to get back on it last night.

First thing was to adjust some code in the webconfig file on the sql server, nothing, next was regenerate and change out the machine key, still no change. Update the DNS servers, no change.

Finally I went through and installed all windows updates, two reboots, (over RDP installed a network card driver which failed, and did not have my server room key, that was fun).

After that, forms authentication was working again. And the sql server stopped generating as many errors, I've gotten two schannel errors since then.

In short, forms authentication began failing when the web server was cloned onto a virtual machine, which caused the sql server to blue sceen? and forms authentication to fail. And could only be fixed by applying patches to the sql server?(I'm wishing I had patched the servers one at a time so I could know for sure which patch on which server fixed it).

My question is why did it fail, and why did patching fix it? I hate fixing something without fully understanding the why and how.

share|improve this question
    
My guess right now is that the service pack changed the way the sql server handled the authentication error, and prevented the blue screen. And something was cached between the two servers allowing the authentication to continue after that update in august, but wasn't carried over in the virtualization process. –  Matt Bear Dec 11 '12 at 17:43

1 Answer 1

up vote 0 down vote accepted

This appears to be a known issue, I am just trying to understand the underlying causes a little better.

http://stackoverflow.com/questions/10094772/microsoft-still-seems-to-have-a-bug-with-forms-authentication-on-webfarm

Is similar, however I am not running a webfarm

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.