Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I need to setup a PPPoE server for IPv6 on Linux machine with RHEL 6.1. When I tried to start pppd, the output was the following:

~$ sudo pppd start
pppd:in file /etc/ppp/options:unrecognized option 'ipv6'

Here is the content of /etc/ppp/options file:

local
ipv6 ipv6cp-use-ipaddr

According to the pppd man page, the option 'ipv6' should be recognized. It puzzled me. I am not sure how to configure the PPPoE server to support IPv6 PPP connections now.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Haven't tried this in practise, but I read the manpage differently in this section:

+ipv6  Enable the IPv6CP and IPv6 protocols.

ipv6 <local_interface_identifier>,<remote_interface_identifier>
      Set  the  local  and/or  remote 64-bit interface identifier.
      Either one may be omitted. The identifier must be  specified
      in   standard   ascii   notation  of  IPv6  addresses  (e.g.
      ::dead:beef). If the ipv6cp-use-ipaddr option is given,  the
      local  identifier is the local IPv4 address (see above).  On
      systems which supports  a  unique  persistent  id,  such  as
      EUI-48    derived    from    the   Ethernet   MAC   address,
      ipv6cp-use-persistent option can be used to replace the ipv6
      <local>,<remote> option. Otherwise the identifier is random‐
      ized.

So I guess you want at least this in your option file:

+ipv6
ipv6
ipv6cp-use-ipaddr

and some IPv4 configuration (see the requirement for ipv6cp-use-ipaddr in the manpage excerpt above).

share|improve this answer
    
I have tried this in practice, and the +ipv6 is what's working for me. –  MadHatter Dec 12 '12 at 13:27
    
Oh,I solve the problem by build my own 'pppd'(with IPv6 Surpport options in Makefile.linux) instead of the default on Integrated in RHLE6.1. Make install,then restart pppoe-server.Then it works~ So,it just because it's not surpported in RHEL on the option of 'ipv6'.~ Thx all~ –  user1897210 Dec 13 '12 at 3:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.