Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a SharePoint 2010 installation where we installed a custom web service (using a .wsp) from a third party (so no access to the source). After installation everything worked fine. When we checked again after a couple of days, we got an error: "Request format is unrecognized for URL ending in " and then whatever operation we tried calling on the web service.

A quick web search suggested to add the HttpPost and HttpGet protocols through the web.config of this web service. We checked and they were already in place.

An application pool recycle fixed the problem. However the next day the problem was back and again an application pool recycle fixed the problem. Does anyone have any clue about how to troubleshoot this?

share|improve this question
1  
Is there no support from the third party vendor? –  Dave M Dec 12 '12 at 13:56
    
I'm waiting for that, but it is likely going to take a long time before they are going to respond, so I'm trying to find other ways to solve this. –  Jonathan van de Veen Dec 20 '12 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.