Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We're having such a big problem in our Centos server in order to have working the SOAP client of PHP 5.3.3.

One of our customers reported us that they were having problems to consume some webservices from the server. They were the firsts that noticed that the SOAP module wasn't aparently installed.

When you execute on php -v that, these errors appears soon:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/fileinfo.so' - /usr/lib64/php/modules/fileinfo.so: undefined symbol: zval_property_ctor in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/soap.so' - /usr/lib64/php/modules/soap.so: undefined symbol: zval_property_ctor in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/sqlite.so' - /usr/lib64/php/modules/sqlite.so: cannot open shared object file: No such file or directory in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/zip.so' - /usr/lib64/php/modules/zip.so: undefined symbol: zval_property_ctor in Unknown on line 0

As you can see, four modules are failing aparently due to the same problem. At least, they are showing exactly the same error. For the time being, the SOAP one is which concerns us the most.

Repo listing from yum shows the:

[root@XXX ~]# yum repolist
Loaded plugins: fastestmirror, replace, security
Loading mirror speeds from cached hostfile
  * atomic: www7.atomicorp.com
 * base: mirror.ovh.net
 * epel: mirror.de.leaseweb.net
 * extras: mirror.ovh.net
 * ius: ftp.rediris.es
 * updates: mirror.ovh.net

I've read that in order to have working this SOAP client JSON support should be enabled too. If I launch 'php -m | grep json' or 'php -m | grep soap' I get nothing.

I supposed that maybe the problem could be solved installing php-json so I tried:

[root@XXX ~]# yum install php-pecl-json
Loaded plugins: fastestmirror, replace, security
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * base: mirror.ovh.net
 * epel: mirror.de.leaseweb.net
 * extras: mirror.ovh.net
 * ius: ftp.rediris.es
 * updates: mirror.ovh.net
Setting up Install Process
Package php-pecl-json is obsoleted by php-common, trying to install php-common-5.3.19-    12.el5.art.x86_64 instead
Package php-common-5.3.19-12.el5.art.x86_64 already installed and latest version
Nothing to do

As you can see there's a conflict with php-common, who supposedly contains already php-json.

Please, any help would be very very appreciated.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.