Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have found on my debian server that running the lighttpd module mod_access is causing the server to response with a 403 to all POST requests.

It's very odd as I have two servers, one is running as I'd expect and the other keeps returning these 403's. They are running identical configs for lighttpd and php.

My lighttpd.conf is: https://gist.github.com/4269500

There is also one other custom conf: https://gist.github.com/4269508

I've opened up the servers for requests until I get this fixed, the server that works is http://mercury.isitup.org/ and the one that fails is http://venus.isitup.org/.

After working out that disabling mod_access resolves the problem I greped all my lighttpd configs for uses of it (docs).

Disabling each line I found didn't help, leading me to think this is perhaps some default behaviour (or bug?)...

Has anyone come across this before or know what configuration value I've got wrong?

Versions

  Debian: Debian GNU/Linux 6.0.6 (squeeze)
Lighttpd: lighttpd/1.4.28 (ssl)
     PHP: PHP 5.3.19-1~dotdeb.0 with Suhosin-Patch (cli)

Cross-Post on the Lighttpd Forum

http://redmine.lighttpd.net/boards/2/topics/5431

Resolution

Using lighttpd -p -f /etc/lighttpd/lighttpd.conf and finding the old values still being loaded. Turned out there was no syslinks but full files instead in conf-enabled.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Use lighttpd -p -f /etc/lighttpd/lighttpd.conf to verify the config looks like you want it to.

share|improve this answer
    
Indeed as pointed out on the forums, using this showed I was not using syslinks in the conf-enabled directory. :| –  Sam Dec 13 '12 at 10:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.