Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Running into a small issue recently that causes my server's atmail to fail authenticating users.

I gathered from a web search that it's because i recently enabled apc on the server.

I've found some reference mentioning I need to modify the atmail vhost template, but that reference is for Plesk 10 (i'm on 9). The atmail config isn't in the same spot.

I've found this unrelated topic that explains how to modify the vhost settings for atmail on plesk 9, which I have done (adding php_admin_flag apc.enabled off to it).

I then recompiled the server config using /usr/local/psa/admin/bin/websrvmng -a but it doesn't seem to pick up the changes.

If I look at /etc/httpd/conf.d/zzz_atmail_vhost.conf after recompiling it still doesn't show the apc settings.

Summary of steps taken:

  • Modified /etc/psa-webmail/atmail/atmail_vhost.conf and added php_admin_flag register_globals off to the config

  • Recompiled with /usr/local/psa/admin/bin/websrvmng -a

  • Checked /etc/httpd/conf.d/zzz_atmail_vhost.conf

But no changes.

What am I missing?

Edit: I was able to go around the issue by adding apc.filters = "-/var/www/atmail/.*" to my /etc/php.d/apc.ini config file. This prevents apc from running on the atmail server files.

Still curious as to why I can't patch the atmail config.

share|improve this question

closed as too localized by Michael Hampton, John Gardeniers, mdpc, Ward, Brent Pabst Dec 14 '12 at 13:25

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.