Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On the this how-to I read the following:

I loaded the following modules to get pci hotplug working:

  • acpiphp
  • pci_hotplug

You can either add these to your distro's module list to load on boot, or run a command like this.

for m in acpiphp pci_hotplug; do sudo modprobe ${m}; done

However, on CentOS 6.3 and Red Hat Enterprise Linux 6.3 this modules does not exist, on Ubuntu Server and Debian 6 it does.

Why? Any workaround?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Probably, it's already built into your kernel (rather than a module). Have you actually tried hotplugging devices?

I don't have access to a CentOS/RHEL machine now, but on Fedora, I see the kernel configuration contains this:

CONFIG_HOTPLUG_PCI=y
CONFIG_HOTPLUG_PCI_ACPI=y

While on Ubuntu 12.04, I see this:

CONFIG_HOTPLUG_PCI=y
CONFIG_HOTPLUG_PCI_ACPI=m
share|improve this answer
    
CONFIG_HOTPLUG_PCI=y CONFIG_HOTPLUG_PCI_FAKE=m CONFIG_HOTPLUG_PCI_ACPI=y CONFIG_HOTPLUG_PCI_ACPI_IBM=m # CONFIG_HOTPLUG_PCI_CPCI is not set CONFIG_HOTPLUG_PCI_SHPC=m –  Giovanni Bennelli Dec 13 '12 at 13:49
    
@GiovanniBennelli So, my thoughts are valid, right? Again: Have you actually tried hotplugging devices? –  gertvdijk Dec 13 '12 at 14:20
    
ok, PCI hotplug support, in the guest, work fine. –  Giovanni Bennelli Dec 13 '12 at 14:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.