Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install PHP MVC framework Symfony. When I go to the check requirements page it says that I have to update my php to version 5.3.17+.

I have an VPS with RedHat. I am totally new in this so I hoped people here could help me with the commands how to upgrade it to php 5.3.17+ or 5.4 (which I prefer).

PHP needs to have PDO working

share|improve this question

closed as not a real question by mdpc, Bryan, Ward, HopelessN00b, dunxd Dec 14 '12 at 12:14

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
if you downvote please give an argument. –  JochemQuery Dec 13 '12 at 18:52
    
For a start: Redhat what? There are at least 3 major versions in use, two of them widespread (v5 & v6) and one out of support (v4). Also: What did you try? Server Fault is no "do my work for me" site. –  Sven Dec 13 '12 at 18:55
    
Also, no one is required to give a comment for up- or downvotes for good reasons. –  Sven Dec 13 '12 at 18:59
1  
@SvenW No one is required. But it could be usefull instead of only downvoting ( there was some big article about this on one of the meta sites) –  JochemQuery Dec 13 '12 at 19:25

1 Answer 1

up vote 1 down vote accepted

With Red Hat and derived distributions, I recommend using the remi repository to get PHP packages (and symfony) to ensure a stable system (though with necessary bugfix updates as well). It currently contains PHP 5.3.19, symfony 1.4.20 and symfony2 2.1.3.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.