Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Samba server running on an OpenVZ VPS with a public IP. I also have a PPTP server running on the same server. I connect to it from a remote Windows PPTP client. I have everything working except network browsing. I can connect and see file shares on the Samba server using explorer and typing \\10.10.0.1. However, I cannot see the server if I refresh network browsing such that it finds the network name. I also cannot see the server if I type \\SambaNetbiosname.

I know that pptp cannot pass netbios traffic but it should work if I enable Samba WINS server and configure pptp server to give out wins server IP which I have. So far I haven't had any luck.

My configuration on the Samba server is as follows. I have created a virtual eth0 interface for the VPS and gave it an ip 10.10.0.1/24. It also has venet0:0 with the public IP. My PPTP client successfully logs into the pptp server public IP and is assigned 10.10.0.2/32 and is also given Wins server IP 10.10.0.1.

I also tried nbtstat -A 10.10.0.1

I thought maybe my problem was the \24 so it is trying to broadcast to 10.10.0.255 which of course won't work so I changed that to \32 but that didn't do anything. I could also be something to do with my samba WINS server setup but hard to mess that up as it's only 2 lines.
wins support = yes

name resolve order = wins lmhosts hosts bcast

I'm kind of surprised I got as far as I did with this because of all the problems I read about Samba on OpenVZ. So far haven't needed bridging to get this far and hopefully that is not what my problem is here since I don't need to bridge out from the server. I just need to get broadcast traffic going between ppp0 and virtual eth0.

share|improve this question
2  
WINS? Really? Why not DNS? WINS has been deprecated for more than a decade. –  Skyhawk Dec 14 '12 at 0:56
    
I run Windows 2008R2 server active directory domains and still use WINS because it is still useful. That is a whole other conversation though and completely off topic frankly because it does not solve my problem of network sharing over VPN with no windows domain. –  Fred Dec 14 '12 at 1:08
2  
Has the Samba server registered its NetBIOS name with the WINS server? If not, that's probably your problem. –  joeqwerty Dec 14 '12 at 1:43
add comment

1 Answer

  1. Install a DNS service with a local domain zone. Perhaps there's one that's already running on your Samba server.
  2. Add an A record for sambanetbiosname.local.example.com.
  3. Configure your PPTP server to issue the DNS server IP address and default search domain to VPN clients.
share|improve this answer
    
I actually got netbios name resolution working. Turns out there is another daemon (nmbd) that handles that and it was not starting. The documentation is not very good on this process. You actually have to start is separately from the smb daemon. Some documentation suggested otherwise. Looking through logs I found nmb didn't like my broadcast address (which doesn't exist) so I removed the broadcast option from name resolve order and bam....nmb starts up properly. However, still do not have network browsing working. Not crazy about going down the DNS path. –  Fred Dec 16 '12 at 1:44
    
So to clarify. I can now access the server by typing \\sambanetbiosname. The last thing is network browsing. Where you press refresh in Windows explorer and it goes out and finds the name on it's own. Still can't get that working. Might give DNS a try but I'd like to get WINS working as well. –  Fred Dec 16 '12 at 2:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.