Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install the latest version of Hyperic (4.6.6) on centos machine and getting this error.

>        /home/hq/agent-4.6.6/bin/hq-agent.sh start Installing the server... Unpacking server to: /home/hq... Creating server
> configuration files... Using "small" installing profile... Copying
> binaries and libraries to server installation... Copying server
> configuration file... Copying server db-upgrade files... Copying
> server libs... Setting up server database... Loading taskdefs...
> Taskdefs loaded Loading taskdefs... Taskdefs loaded
> -------------------------------------------------------------------------------- An ERROR occurred, the installation cannot continue. FATAL EXCEPTION
> at /home/hq/hyperic-hq-installer-4.6.6/installer/data/setup.xml:523: :
> The following error occurred while executing this line:
> /home/hq/hyperic-hq-installer-4.6.6/installer/data/setup.xml:532: The
> following error occurred while executing this line:
> /home/hq/hyperic-hq-installer-4.6.6/installer/data/setup.xml:777: The
> following error occurred while executing this line:
> /home/hq/hyperic-hq-installer-4.6.6/installer/data/setup-db-MySQL.xml:16:
> The following error occurred while executing this line:
> /home/hq/hyperic-hq-installer-4.6.6/installer/data/setup-db-hibernate.xml:94:
> org.hibernate.tool.hbm2x.ExporterException: Errors while performing
> Hbm2DDLExporter
> -------------------------------------------------------------------------------- Deleting temporary JRE

I have already looked for the DB connection and everything is fine. I tried to google search, but didn't find any help anywhere.

I know you might need more info, so feel free to comment and I will update whatever I can.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The problem was with the Mysql Version.

I was using mysql version 5.5 and Hyperic somehow wasn't supporting it.

I tried the installation with the Mysql Version 5.1, and it worked like charm.

Hope this post will help someone who is trying to get a solution for this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.